2.3.1 NUT won't start

  • I just grabbed a new UPS so I installed the NUT package but it wouldn't start from the GUI so I tried starting it manually. It appears the executable is missing

    [2.3.1-RELEASE][admin@chadhome.cox.net]/var/log: /usr/local/etc/rc.d/nut.sh start
    starting cyberpower
    Network UPS Tools - UPS driver controller 2.7.4
    Can't start /usr/local/libexec/nut/cyberpower: No such file or directory
    cyberpower failed to start

    doing this makes it get a little farther

    ln -s powerpanel cyberpower

    [2.3.1-RELEASE][admin@chadhome.cox.net]/usr/local/libexec/nut: /usr/local/etc/rc.d/nut.sh start
    starting cyberpower
    Network UPS Tools - UPS driver controller 2.7.4
    Network UPS Tools - CyberPower text/binary protocol UPS driver 0.27 (2.7.4)
    Warning: This is an experimental driver.
    Some features may not function correctly.

    Unable to open auto: No such file or directory

    Things to try:

    • Check 'port=' in ups.conf

    • Check owner/permissions of all parts of path

    Fatal error: unusable configuration
    Driver failed to start (exit status=1)
    cyberpower failed to start

    It seems the auto usb selection doesn't work so I need to set it statically. I see this in dmesg when the UPS is attached

    ugen0.4: <cps>at usbus0

    but I dont see anything like that in the list of port choices.

    Not sure where to look next.


  • The cyberpower driver doesn't exist in NUT any more. If your UPS supports USB-HID, which is pretty likely, you can choose any of the USB-HID models and it will work. "APC Back-UPS USB" is an example. Choose "auto (USB only)" as your port.

  • Thanks man. That worked perfectly. I thought I was looking at currrent docs on this but I must have pulled up some old driver to ups matrix.


Log in to reply