Upgrade from GUI bricked firewall

  • I chose the upgrade option yesterday and after quite a long time lost connection to the gui. I rebooted and could not connect.
    I connected to the console with my Keyspan and teraterm and watched it boot. It looks fine unitl it tries to boot from the 4gig flash card. At that point the display shows only giberish for a while and stops.
    The default serial settings are 9600, 8, n, 1, none. I tried higher port speeds with the same result. I downloaded the 4G-i386-nanobsd-img, wiped the partitions and reloaded the image. The result was the same as before. I then tried the 2G image and still have the giberish display after the machine tries to boot the image. Does anyone have any suggestions?

  • No It's not the serial settings. The manufacturer  states 9600 on the label on the bottom of the device and I have tried every setting between 1200 and 128,000 with the same result.
    That is as soon as the kernel loads it spews a few lines of gibberish and stops. Prior to that it displays the motherboard boot stuff perfectly.

    NEW DEVELOPMENT: Now it no longer tries to boot the kernel, It displays "DISK BOOT FAILURE".  So I'm thinking that the 4gig flash card is bad now.
    I'd like to try a different CF card. I want to be sure about the correct size of the image. Is the 4Gig image correct for a 4gig CF card or should I use the 2gig image?

  • still the serial settings are wrong … doesn't matter what the manufacturer states.

    the manufacturer states the serial settings that are in use when the OS has not taken over (while the BIOS is in control).
    somewhere in the bootprocess, pfSense takes over and puts the serial settings to something different ( as noted in the link i've posted)

    the 4GB card should work with a 4GB image

Log in to reply