• Hi all,

    I'm relatively new to Pfsense. As in, after using pfsense on a free given home computer (Intel dual core with 8gb ddr3) for making a wifi-network on a small scale festival, 600 people were online that day o.0, used squid with monitoring and traffic shaping, plus blocking heavy traffic websites, all worked like a charm. I thought: wow, this is something really powerfull.

    I wanted to throw out the genexis fibermodem I've got from my ISP; used a tp-link SFP-converter to convert fiber to gigabit ethernet.
    The fiber network that is around here is a bit rare. So it's not like the ISP everyone has in het Netherlands (like KPN). Though their manuals were helping a lot, usually with only a few minor differences.

    The amount of topics i've read so far regarding this subject is huge, but none were really helping. And i've been fiddling with it so many times now, without much result, I thought it was time to ask for help :)

    The thing is, my provider makes use of a PPPoE connection on a VLAN. (I've got 160mbps up and down, where I only pay for 150mbps up and down, nót complaining there,)
    I found the password in the old router (Hit save, then firefox popped up and said: you want to save this password? Which I said yes offcourse ;)  )

    So I've configured the correct gateway, VLAN om em0; and then fill in the PPPoE accountname and password; voila, i've got internet. (Short version)

    Untill I reboot;
    I can see in the logs that pfsense wants to open the WAN_PPPoE connection but it says "Link down". So, it appeared to me that they want to open the VLAN first. Which I now do manually; assign interface, select WAN with vlanxxx on em0, I see the connection with 1000x duplex, the wan port changes from DOWN to UP, but still no internet, untill I fill in the PPPoE connection.

    Things I tried so far: Make second interface with VLAN on em0, bridge this with interface PPPoE on em0, make the correct firewall rules, nothing, vlan 3404 up and PPPoE connection down with error 65. (Other way around as well), made a static route, I've got internet for exactly 10 seconds; so I reverted back to the way i did it first)

    So, is there a way to have the following: first open vlan on em0 and thén fill in the credentials? Because right now, if there is a power outage, I've got no connection, untill i'm home…..

    The other thing that occured to me was that the option above does not work at all in 2.3.2 (So i went back to 2.3.0). Was there a change between these 2 versions, regarding this area?

  • Well, apparently it's something that has been hunting Pfsense from quite some time now, If I look into the topics; It's not the cannot remove hook: https://forum.pfsense.org/index.php?topic=31409.0

    But it looks a bit more like this:  https://forum.pfsense.org/index.php?topic=109145.0  The log files in this topic look identical, except I use a pci-e intel quad NIC Pro/1000 PT, not something on USB.
    So I used the onboard realtek NIC as WAN-port … no difference :(

    And then this: https://forum.pfsense.org/index.php?topic=87239.0    With the difference, simply saving is not sufficiënt, I have to fill it in manually.

    In another topic there is reference of reverting back to 2.2.1 .... But I like 2.3. :(
    I'm gonna try this tonight: https://redmine.pfsense.org/issues/6495

  • @Feather:

    Things I tried so far: Make second interface with VLAN on em0, bridge this with interface PPPoE on em0

    Why do you think you have to bridge something?

    Create a VLAN on the interface that physically connects to your modem/media converter with the correct VLAN-ID.
    At  Interfaces: PPPs  you create a PPP connection using the newly created VLAN as interface. Enter your credentials here.
    Delete any garbage from recent tries.

    That should be it. A reboot sometimes does wonders.

  • Well, that's the whole problem … I started dabbling with it, because after a reboot it will not create a PPPoE connection.....  I did exactly as you're saying in the first place.

    So, everything works, untill a reboot. :)

  • What type of media did you install on? Sounds like read only.

  • 32gb SSD; The settings are there when pfsense reboots; but it cannot make the PPPoE connection (So in PPP settings, i'm looking at the username and password with the dots), it doesn't make a connection,
    untill first switching back in "assign interface" to the network port "vlan on em0";and then manually fill in the PPPoE username and password. But

    Can't I make a cron-job startup script?
    1 assign interface WAN > network port Vlan_ on em0
    2 fill in PPPoE username, password on vlan_on em0 ?

  • Hi,
    How did you go with this did you find a resolution?

  • This appears to still be an issue.

    My ISP (FTTH provider) initiates a PPPoE session over VLAN35, upon boot pfSense is unable to/or does not initiate the PPPoE session until the PPPoE interface is removed and re-added to the WAN assignment. The PPPoE session will remain active until reboot or power loss, at which time the above mentioned steps need to be performed again.

    Currently on version 2.4.4-p2

  • Netgate Administrator

    Please start a new thread for this. Whatever you're hitting is unlikely to be the same issue from 3 years ago.

    It's a not a general issue, I have two PPPoE WANs here and both are on VLAN interfaces. No issues in 2.4.4p2.

    There were some issues in 2.4.4 though.


Log in to reply