OpenVPN - TLS handshake failed



  • Witam.
    Mam pewien problem z połączeniem OpenVPN. Skonfigurowałem połączenie z firmą pracownikowi, połączenie działa bezproblemowo, do momentu w którym próbuje połączyć się ze swojego "domowego" internetu od jakiegoś lokalnego dostawcy. Objawem jest jak to opisuje "cały czas żółty ekranik".
    W logach po stronie serwera mam:

    Sep 28 12:50:00 openvpn 49715 46...:1194 TLS Error: TLS handshake failed
    Sep 28 12:51:02 openvpn 49715 46.
    ..:1194 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

    Status/OpenVPN: mam użytkownika UNDEF bez przydzielonego wirtualnego IP.

    W logach klienta:
    Wed Sep 28 12:56:23 2016 OpenVPN 2.3.12 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Aug 23 2016
    Wed Sep 28 12:56:23 2016 Windows version 6.2 (Windows 8 or greater) 64bit
    Wed Sep 28 12:56:23 2016 library versions: OpenSSL 1.0.1t  3 May 2016, LZO 2.09
    Enter Management Password:
    Wed Sep 28 12:56:24 2016 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
    Wed Sep 28 12:56:24 2016 Control Channel Authentication: using 'server.tls-auth' as a OpenVPN static key file
    Wed Sep 28 12:56:24 2016 UDPv4 link local (bound): [undef]
    Wed Sep 28 12:56:24 2016 UDPv4 link remote: [AF_INET]94...**:50001
    i na tym koniec.

    Konfiguracja klienta:
    keepalive 10 60
    ping-timer-rem
    persist-tun
    persist-key

    cipher AES-128-CBC
    auth SHA1

    tls-client
    proto udp
    dev tun
    client
    remote 94...** 50001

    ca VPNCA.crt
    cert User1.crt
    key User1.key
    tls-auth server.tls-auth 1

    comp-lzo adaptive
    resolv-retry infinite

    Czy może ktoś ma pomysł gdzie może być problem? Będę wdzięczny za pomoc…


Log in to reply