Very Low signal strength

  • I am using Atheros 5213 minipci on Soekris 4501. Signal strength is very low. I can only connect when I am two feet away from the AP.

    I pulled it off of the Netgear router I had. I am using the original antenna. I also have an standard Atheros PCI with antenna attached. I also have same issue with it.

    Any help will be appreciated.


  • Please provide the output of "ifconfig -v ath0"

  • ifconfig -v ath0

    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
            inet6 fe80::20f:b5ff:fe0b:d3b5%ath0 prefixlen 64 scopeid 0x1
            ether 00:0f:b5:0b:d3:b5
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
            ssid Soekris channel 9 (2452) bssid 00:0f:b5:0b:d3:b5
            authmode WPA privacy MIXED deftxkey 2
            TKIP 2:128-bit
            TKIP 3:128-bit powersavemode OFF powersavesleep 100 txpowmax 40
            txpower 63 rtsthreshold 2346 mcastrate 1 fragthreshold 2346 -pureg
            protmode OFF wme burst ssid SHOW -apbridge dtimperiod 1 bintval 100
            AC_BE cwmin  4 cwmax  6 aifs  3 txopLimit  0 -acm ack
                  cwmin  4 cwmax 10 aifs  3 txopLimit  0 -acm
            AC_BK cwmin  4 cwmax 10 aifs  7 txopLimit  0 -acm ack
                  cwmin  4 cwmax 10 aifs  7 txopLimit  0 -acm
            AC_VI cwmin  3 cwmax  4 aifs  1 txopLimit  94 -acm ack
                  cwmin  3 cwmax  4 aifs  2 txopLimit  94 -acm
            AC_VO cwmin  2 cwmax  3 aifs  1 txopLimit  47 -acm ack
                  cwmin  2 cwmax  3 aifs  2 txopLimit  47 -acm

  • Any chance you use the wrong antenna port ?
    Also, you might want to try to lower the output power. If the card has a poor rf output it might be generating too much noise.
    I have not encountered any behaviour like this with pfsense/freebsd, so this is just a guess.
    You can also try to play with the following sysctls from a shell.

    dev.ath.0.txantenna: 0,1,2 (antenna port 0 or 1, both=2)
    dev.ath.0.rxantenna: 0,1,2 (antenna port 0 or 1, both=2)
    dev.ath.0.diversity: 0,1 (0=disable 1=enable)
    dev.ath.0.tpscale: 0,1,2,3,4 (size of increment that TPC will use to up/down the power, normally 1 is the best choice, atleast that is my experience)
    dev.ath.0.tpc: 0,1 (0=disable 1=enable)
    dev.ath.0.tpack: 63 (ack power)
    dev.ath.0.tpcts: 63 (cts power)

    A little more description:

    dev.ath.0.txantenna: The antenna used to transmit (normally the same as RX antenna)
    dev.ath.0.rxantenna: The antenna used to receive (normally the same as TX antenna)

    (A different RX antenna can be used if your regulatory restrictions makes you want to use a higher RX gain antenna to overcome the output limits of your regdomain. An example would be; you can only output 20db E.I.R.P on a long distance link, and to overcome the signal loss you use a higher gain antenna for RX gain, since you are not transmitting at more then 20dbi you can still receive with 36dbi or more if you like too, as the regdomain restriction is normally only applied to transmitting power and not receive gain. This is perfectly leagal in all of the regdomains as far as I know)

    dev.ath.0.diversity: Switch off and on the use of antenna diversity (normally only used if you have two antennas connected)
    dev.ath.0.tpc: Switch on or off Transmission Power Control (can be tricky in point to multipoint applications)
    dev.ath.0.tpscale: Size of the increment that TPC will use to up/down the power, normally 1 is the best choice, atleast that is my experience. A higher scale value will most likely make the link drop if the signal is close to what it needs to be and the TPC is trottled down.)
    dev.ath.0.tpack: controll the ack power seperatly (normally the same as tpcts)
    dev.ath.0.tpcts: controll the cts power seperatly (normally the same as tpack)

    All this will be controlable from GUI in 1.1 (1.0 is frozen so no new features there)

    EDIT: this info is added to the wiki
    EDIT2: this info is also added to the doc site:

Log in to reply