Custom domain?

  • I may be missing something very simple here, but I am having difficulty figuring this out so I thought I would ask for help…

    Say I want to set up my own custom domain limited to my LAN, for internal use only?  The aim is to have a made-up address, like "hello.goodbye" that would (obviously) be routable on the LAN only, not externally, to be used for easy reference for servers in my LAN (such as my NAS).  How might one go about adding the necessary entries in DNS resolver so that the address resolves to the correct LAN IP (assuming this is even possible)?

    Any help would be appreciated.

  • LAYER 8 Global Moderator

    This is how it would be out of the box.. What domain did you give pfsense?  I use local.lan for my local domain.  If you register dhcp clients then they would all resolve via theirname.yourdomain.tld

    You can then for sure add host overrides for boxes that might be static, or if you don't want to register dhcp clients, etc..

    so for example.  My storage box..

    dig storage.local.lan

    ; <<>> DiG 9.10.4-P3 <<>> storage.local.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22285
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ; EDNS: version: 0, flags:; udp: 4096
    ;storage.local.lan.            IN      A

    storage.local.lan.      3600    IN      A

    ;; Query time: 0 msec
    ;; SERVER:
    ;; WHEN: Sun Oct 16 08:48:51 Central Daylight Time 2016
    ;; MSG SIZE  rcvd: 62

  • I appreciate the help.  For some reason, when I tried to access the domain in question today, it worked.  Not sure what changed to make it work, but that is fine with me.

  • LAYER 8 Global Moderator

    Do you have your client point to more than just pfsense for dns?  Without knowing your setup it is impossible for me to guess what you were having issues with.  But what I can tell you is this is how pfsense is designed to work right out of the box.

  • Nope - the only DNS server used is the pfsense box.

    I think the mistake was that I used a hello.goodbye, instead of NAS.hello.goodbye. I assigned a host override in DNS resolver for hello.goodbye, to redirect to the local IP address. Now when I type in the originally desired NAS address (hello.goodbye), it redirects to the correct internal IP address.  Is that the right way to do this?

  • LAYER 8 Global Moderator

    if your domain is hello.goodbye then a proper FQDN for host would be host.hello.goodbye

    if you wanted something to resolve with just hello.goodbye then when you create the override your host would be hello and your domain would be goodbye

  • That is exactly what I had done.  Thanks for confirming!