Watchguard Firebox x550e drops WAN and LAN randomly

  • Hello all!

    I have had a few problems with my switch to a Firebox x550e. I have watched all the videos I could find on the flashing process as well as read through most of the posts here and I have not seen 1 post about this problem.

    I am able to get PfSense 2.3.2 to run fine on the Firebox but for some reason (at random times) the LAN and or WAN will drop out unexpectedly and the only way to fix it is to reboot, reset the states table, or pull the ethernet cord out and plug it back in. This becomes a problem when it has to be done every 10 mins to an hour….

    My setup is: Verizon Fios Actiontec Router --> PfSense --> 24-Port Netgear Switch --> Multiple clients and IP's

    I am still using the DHCP from the Verizon router because of the cable boxes.

    Things I have tried:

    • I have lowered the buffer to 2MB thinking maybe it was overwhelmed, Nothing changed.

    • Checked Disable Hardware Checksum Offloading as well LRO and TCP segmentation

    • Tried using every combination of ports with no luck

    • Tried a clean install

    • Tried disabling the LCDProc package with no luck

    I am sure there is more I have done but I have worn myself out with trying different things.

    Does anyone have any ideas??

    Thanks in advance for any advice!

  • Netgate Administrator

    Anything logged in the system log?

    Anything related to the sk driver on either of those interfaces in particular?

    You can try disabling MSI/MSIX if for some reason that's causing an issue. I've not seen anything with the sk NICs though.


  • Just got your reply. Apologies!

    Thanks for the advice!

    Yes I have tried to disable the msk driver with no luck.

    I took a look at the logs and it showed nothing more than the interface going down and it being unable to connect to the Verizon router at

    I put the project aside for now but I do have an extra Intel quad server NIC that I might test with using the PCI-e x4 slot on the motherboard.

    In the meantime, I am using my original PfSense router so at least I am not completely screwed.

    Thanks again,

  • Netgate Administrator

    Hmm, hard to say with nothing logged.
    I have once seen odd behaviour on those NICs with hardware checksum offload still enabled (the default setting). However it didn't block traffic completely. It's worth trying though.


Log in to reply