Pfsense cannot allocate specific amount of bandwith?



  • Hello,

    There are some users in office LAN who are using too much bandwith by watching films/download/upload etc…, is there a way I can allocate specific amount of bandwith to these users. We know that the LAN IP is fixed by those users so can I limit bandwith to a specific user via LAN IP?

    One way I achieved this by:

    Firewall -> traffic Shaper -> (I have created 2 limiter here 'Uploadspeed' and 'Downloadspeed') -> under bandwith option I have added 1 and burst I've added 3 Kbit/s (it was 5 and 8 but this made no difference, so I decided to lower it down)

    I've applied this rules by going to Firewall -> Rules -> Created a rule -> added a specific LAN IP -> under Advice feature In/Out I have selected Uploadspeed / Downloadspeed (created in traffic Shaper section)

    However I dont think this working because after applying this tule to a user he can still use more bandwith than allocated via rule.

    Any thing that I am doing wrong, or is there any other way I can achieve this?



  • Depends on the way you configured the limiter. It could be limiting the IP to 3kb/s or it could be limiting each connection that IP makes to 3kb/s.

    This same question is asked nearly every week and there are clear tutorials on how to configure. You would have done better asking in the "Traffic Shaping" forum instead of "Firewall", but I'm sure others will see.

    So far you have only given abstract ideas of what you have done, and they sound "correct", assuming you did all of the detailed steps correctly. Seeing that you are claiming it is not working, it's probably because you did not do the steps correctly. It is difficult to help you if we have to guess at what you did wrong. It would be helpful to see some exact details of the limiter configuration and the firewall rule along with it's position relative to other rules and which interface it is on. This information is many times just attached as screenshots since they're universally simple to do.



  • Yes your correct - there was something wrong with my config (now it works as expected).

    Things I changed:
    Nothing was required in Bust option (dont know what that is?)
    Under Gateway, I need to select my WAN settings.

    This video was help full:
    https://www.youtube.com/watch?v=-zHywYMoRxc