Opt2 stops working when VPN is turn on



  • I'm having a bit of an issue, I have 3 nics (wan/lan/opt2)

    lan and opt2 have different subnets and each have dhcp enabled

    on lan I use a 24/7 vpn connection

    on opt2 I use an AP to serve devices I want to connect to hulu and netflix

    everything works ok, I have dhcp working on each interface, can ping back and forth the 2 subnets, can access the Internet

    the problem is that when I turned the vpn service on,  opt2 stops working I can still get an ip on devices but can't browse the interne, it all goes back to normal when I turn the vpn off, but I really want VPN on at all times on the lan interface

    also when the VPN is turn on I get the VPN ip on lan and still get my real ip on opt2 when I search what's my ip, so I would think that there is no overlap

    suggestions?

    thanks


  • Rebel Alliance

    Send an image of your routing table, once with vpn on, second without vpn running.

    Fairly certain it won't be me, but someone should be able to diagnose the issue pretty quickly with that info.

    Good luck.



  • Don't mean to hijack OP post but this is the closest post I've seen to my situation. Basically same setup as OP, OPT1 is a 24/7 vpn connection. In my case i am able to ping, surf the webs not issues there. I have a NAS on the LAN side, no security so it can be access by anything.

    on a workstation that is on the vpn/opt1 network i  can mount a share on the nas open a file. The strangest issue i have is i cannot copy any files to the share. The errors i get are not permission related. They are network related on a mac it says error -36 on a pc is error 0x8007003b, on linux it copies 98% of the file and then it just times out.

    However if a move the pc to the LAN and replicate, it copies to the share no problem. My point of failure is my pfsense box (as far as copying from one network to the other).  I am running 2.3.3





  • LAYER 8 Global Moderator

    Well sniff the traffic and see what is going on..

    BTW your lan rules make no sense.. You have a any any rule on the top, so all those rules below pointing to PPPoE are meaningless.



  • I took the screen shot after I put that one in just trying  to get something to work.


Log in to reply