VOIP ATA States not reseting in pfsense after WAN IP Changes.



  • Hi,

    background, I have encountered a situation a few times now that when my WAN IP receives a new IP from my ISP, my VOIP stops working until I manually clear out the stale states in pfsense, where the ATA in pfsense 'States' section has a stale state with the prior WAN IP trying to reach my voip provider, this occurs many minutes/hours sometimes after the WAN IP change, for some reason, the state remains stale with the old WAN ip, even after resetting the ATA to see if that breaks the stale state connection.

    question, is there a way that when my WAN changes the states all auto clear, or a config/setting i can modify so that when the WAN ip changes, states refresh faster?  this only is an issue with VOIP as it is in constant contact with my voip provider.

    more info if required, my setup is a ATA -> switch -> pfsense -> VOIP provider.

    this has occurred with prior versions of pfsense, currently running 2.3.2-RELEASE-p1

    States area in pfsense I'm referring to is pfsense menu Diagnostics -> States, hitting the garbage bin beside the states removes it and allows the ATA to reestablish a connection with the voip provider.

    thank you in advance for your help.

    ip.



  • This has been an ongoing bug for many years it seems.  I don't know if there is a workaround, but there are a lot of posts from people complaining about it, and a few bugs in redmine that are literally years old.  While this is still a problem, why is your ISP changing your WAN IP on a regular basis?  Is this a failover config?



  • Hi, thank you very much for your help and quick reply.  that is unfortunate that it has been an ongoing issue.

    my ISP, over the many years provides a new ip's at from what i can tell random times, maybe ~3 times a year on average, sometimes i'll go a year with one ip,  they only provide dhcp, static ip's cost extra.  so my voip phone not working doesn't happen often thankfully, more of a nuisance where i may go days with the phone not working because i haven't used it.

    after reading your reply, i looked up redmine and came across a script someone was working on
    https://redmine.pfsense.org/issues/8  something i'll look into, or a custom method to notify me when my WAN ip changes for manual or script intervention to flush the states in some fashion.

    ip.



  • I'm having this issue on failover and failback with a gateway group, regardless of the kill states on gateway failure checkbox. My phones just die until rebooted or states manually flushed. I'd LOVE to see a permanent fix.



  • I am running 2.4.4-RELEASE-p3 (amd64) the throughout updates the issue initially mentioned is still occurring. about once or twice a year i get a new WAN IP from my provider and my VOIP service no longer works, and within the states it still has the old WAN IP. i have to manually kill the states for it to refresh and work.

    i also have Under System / Advanced / Networking

    i have checked


    where it says "Reset all states if WAN IP Address changes This option resets all states when a WAN IP Address changes instead of only states associated with the previous IP Address"

    even with above checked, the same issue mentioned initially in my post is still occurring.

    is this still a known issue?


Log in to reply