How do I fix this error in HAProxy?


  • [WARNING] 041/090521 (61632) : Setting tune.ssl.default-dh-param to 1024 by default, if your workload permits it you should set it to at least 2048. Please set a value >= 1024 to make this warning disappear.

    I am running HAProxy 1.7.1

    Thanks,

  • Banned

    This is not any error in the first place. And DH is configurable in HAproxy settings GUI.


  • Also encountered and solved this error. To fix, set the "Max SSL Diffie-Hellman size" to be >= 1024

    In version 1.8.25 it is in the third from last option group