Doubt about the MTU in pfsense 2.3.3

  • I have a doubt about the MTU in pfsense 2.3.3

    ipv6 do not work anymore in 2.3.3 for me
    my ISP use 6rd, I have to set 1480 to my lan interface to let ipv6 works (it works before 2.3.3)

    external gateway is reachable
    ping6 is ok

    all ipv6 websites are reachable (ie. ping6) but do not appears thru my browser (Firefox/Chromium) , same behavior when I did not set 1480 mtu on the lan interface (at each reboot) in pfsense 2.3.2

    about the new traffic graph :
    It looks very good but it miss now a useful things, the current real time traffic in the upper left is not here anymore…
    Now you have to mouse over the graph to see this information
    Firefox even in multi process windows mode use now 86-100% of 1 core of my cpu (i7 4C/8T) with the new UI

  • Strange. It works fine for me without setting the LAN MTU to 1480 in 2.3.3 with 6rd. In fact, I have never changed the LAN MTU.

    I set wan_stf's MTU to 1480 and the the MTU of the routes on wan_stf to 1480.

    what does show when it is not working vs when it is working?

  • give me a 10/10 when it is not working & when it worked

    ipv6 websites display nothing thru Firefox (permanent loading) & give me : "This site can’t be reached , took too long to respond." in Chromium/Chrome

    Where do you set wan_stf's MTU& MTU of the routes  ?

  • Getting 10/10 generally means everything is fine. That site does a bunch of tests for IPv6. Getting 10/10 is supposed to mean it all worked. Maybe just doesn't work?

    Maybe post your radvd.conf file. You can get it from the console, SSH, or Diagnostics -> Command Prompt by running:

    cat /var/etc/radvd.conf

    One other thing I thought of: every time I reboot I have to go to WAN and resave the interface to get IPv6 actually working. Happens with 6rd and DHCP6-PD.

    Go to Interfaces -> WAN. Click save, click Apply. See if that helps.

    As for the MTU stuff, I don't think it's related to your issue anymore but you can run these commands on the console (SSH) to get & set the MTU of wan_stf to 1480 (I do this for performance reasons). I would recommend not messing with the MTU until after your issue is resolved.

    ifconfig wan_stf mtu 1480
    netstat -r -n

    find each destination with an entry in the Netif column that belongs to wan_stf

    route -6 change <destination> -mtu 1480
    route -6 get <destination></destination></destination>

    Again, not sure why 2.3.3 would make a difference for you. Everything is pretty much the same for me (including IPv6 not working until I resave the WAN interface).

Log in to reply