Inssue with Intel SpeedStep settings



  • Hi there,

    I up/downgraded my pfSense box from a Xeon SuperMicro to a Dell i3-540 R210, mainly to minimize the power consumption. Since then I'm seeing this during the boot:

    CPU supports enhanced SpeedStep, but it's not recognized
    

    What does it telling me? Some of the Google searches suggest that FreeBSD has issues recognizing SpeedStep for some Intel CPUs. How do I fix that?

    -Santanu



  • any/no one having this issue?
    Not sure, if i can call it an "issue" but nice to have a clean startup.

    -S



  • I haven't seen that on my Xeon, however I get this on bootup (Supermicro X8SIL-F w/ x3470):

    est0: <enhanced speedstep="" frequency="" control="">on cpu0
    est1: <enhanced speedstep="" frequency="" control="">on cpu1
    est2: <enhanced speedstep="" frequency="" control="">on cpu2
    est3: <enhanced speedstep="" frequency="" control="">on cpu3
    est4: <enhanced speedstep="" frequency="" control="">on cpu4
    est5: <enhanced speedstep="" frequency="" control="">on cpu5
    est6: <enhanced speedstep="" frequency="" control="">on cpu6
    est7: <enhanced speedstep="" frequency="" control="">on cpu7</enhanced></enhanced></enhanced></enhanced></enhanced></enhanced></enhanced></enhanced> 
    

    So I assumed that it worked, but sysctl reports max freq + 1 Mhz (== Turbo boost) permanently and doesn't seem to lower the clock in idle.
    PowerD is enabled and set to Hiadaptive.

    EDIT:
    Just checked IPMI, the sensors show vcore adjustments. This means Speedstep should work_s_ as intended. Is this a bug in sysctl?

    EDIT:
    Works as intended for me. Hiadaptive was just too aggressive. Adaptive shows scaling:

    sysctl dev.cpu. | grep freq
    dev.cpu.0.freq_levels: 2934/106000 2933/95000 2800/82000 2667/70000 2533/62000 2400/53000 2267/46000 2133/39000 2000/33000 1867/28000 1733/24000 1600/20000 1467/17000 1333/14000 1200/11000
    dev.cpu.0.freq: 1333
    




  • Can you enable power management in the BIOS?
    Also this will show if speedstep is recognized:

    grep -i speedstep /var/run/dmesg.boot
    


  • Power management is set to "Active Power Controller", which

    • Enable Dell System DBPM (BIOS will not make all P states available to OS)

    • Memory frequency = Maximum Performance

    • Fan algorithm = Minimum Power

    This is what I see in the dmesg:

    [2.3.3-RELEASE][admin@pfs17.littlehome.co.uk]/root: grep -i speedstep /var/run/dmesg.boot
    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est2: <enhanced speedstep="" frequency="" control=""> on cpu2
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est3: <enhanced speedstep="" frequency="" control=""> on cpu3
    est: CPU supports Enhanced Speedstep, but is not recognized.</enhanced></enhanced></enhanced></enhanced>
    


  • The Maximum Performance may be stopping the CPU's from any energy efficiency.
    Is there any other option available other than Max Perf.