Pacote não oficial E2guardian para software pfsense® - Adeus squidguard :D



  • @marcelloc:

    tenta isso aqui:

    
    mkdir -p /var/squid/logs
    chown squid:proxy /var/squid/logs
    
    

    mkdir -p /var/squid/logs
    A pasta ja existe, estou usando o pacote do squid dai ele ja criou

    chown squid:proxy /var/squid/logs
    Ja esta setado como squid:proxy



  • Vou subir uma vm do zero para ver qual permissão está faltando.

    quais as permissoes que aparecem na sua pasta /var/log/e2guardian?



  • @marcelloc:

    Vou subir uma vm do zero para ver qual permissão está faltando.

    quais as permissoes que aparecem na sua pasta /var/log/e2guardian?

    Resultado:
    drw-r–r--  3 clamav  nobody    512 Jul  7 13:18 e2guardian



  • @marcelloc:

    tenta isso aqui:

    
    mkdir -p /var/squid/logs
    chown squid:proxy /var/squid/logs
    
    

    Está para o usuário certo.

    Faz o seguinte, até eu conseguir subir a vm pra testar, coloca um 775 na pasta



  • @marcelloc:

    @marcelloc:

    tenta isso aqui:

    
    mkdir -p /var/squid/logs
    chown squid:proxy /var/squid/logs
    
    

    Está para o usuário certo.

    Faz o seguinte, até eu conseguir subir a vm pra testar, coloca um 775 na pasta

    Resolvido Marcello….

    O problema esta bem ai mesmo, criou o arquivo access.log na pasta /var/log/e2aguardian e o mesmo startou sem problemas



  • Buenas!

    Galera,

    Acabam de ser publicados uma série de screencasts gratuitos no Sys Squad. Dentre eles, há um que aborda o passo-a-passo para instalação e principais opções de configuração do E2guardian.

    Para acessar, basta seguir: http://sys-squad.com/screencast/59

    Abraços!
    Jack



  • Eu queria um passo a passo também detalhado do e2guardian



  • Estou vendo já os vídeos. Como faz para ficarmos com a versão 2.4?



  • @danilosv.03:

    Estou vendo já os vídeos. Como faz para ficarmos com a versão 2.4?

    snapshots.pfsense.org



  • Pessoal, boa tarde,
    desculpe se estou postando no tópico errado mas é minha primeira postagem aqui no fórum.

    Sou novo no pfsense e instalei o E2guardian pois atendia às minhas necessidades, felizmente consegui configurar tudo com sucesso(depois de alguns imprevistos).

    O único problema agora está na página de bloqueio, não consigo mudar os caracteres dela, customizar de acordo com o que preciso aqui. Já encontrei o arquivo .PHP da pagina de erro, modifiquei, porem quando executo ainda permanece a mesma frase.

    Alguém poderia me dar uma dica de como modificar esta tela?

    Desde já agradeço.!!!



  • O report html padrão fica na aba report and log



  • @marcelloc:

    O report html padrão fica na aba report and log

    Vlw amigo… consegui editar, muito obrigado ;D ;D ;D



  • Acabei de subir a versão 0.4.2.6 para o repositório

    O que tem de novo:

    • Inclusão das categorias nos arquivos de blacklists aplicados

    • Correção das permissões da pasta de logs e ssl

    • Verificação do .Include selecionados dos arquivos de exemplo

    • Utilização do E2guardian versão 4.1.2

    Caso tenha dificuldades na instalação, reinstalação ou update, verifique na console ou nos logs do sistema que erro está recebendo.

    Se estiver relacionado a permissão, execute:

    chmod 755 /usr/local/etc/e2guardian/ssl
    chmod 755 /var/log/e2guardian
    

    Se estiver recebendo erros de arquivos de configuração faltando ou libs do openssl, tente a reinstalação via console com o parametro -f

    pkg install -f e2guardian
    


  • Pessoal, estou enfrentando um problema difícil de resolver aqui, já pesquisei em mil lugares.

    Meu PfSense com E2guadian está barrando o download dos driver com o Driver Easy, já coloquei nas regas, na Exception do E2guardian, mesmo assim está barrando o download do Driver Easy.

    Descobri que a URL que p Driver Easy utiliza são essas:
    dow0.drivereasy.com/
    dow1.drivereasy.com/

    porem mesmo colocando elas na Exception ainda sim não consigo.

    Alguém pode me ajudar em relação a isso, por favor.

    Desde já agradeço!!!



  • Qual erro você recebe? O que aparece nos logs?



  • @marcelloc:

    Qual erro você recebe? O que aparece nos logs?

    Marcelloc estou no lab de informática da escola formatando as maquinas e em todas o Driver Easy da o erro:

    "File size has changed, cannot download this site

    Sempre usei esta versão do software e por isso creio q o problema nao seja com ele.

    Não sei como achar o log do PfSense que acuse o erro, poderia me ajudar?



  • Vai na aba realtime do pacote mesmo e filtra pelo ip da estação.



  • @marcelloc:

    Acabei de subir a versão 0.4.2.6 para o repositório

    O que tem de novo:

    • Inclusão das categorias nos arquivos de blacklists aplicados

    • Correção das permissões da pasta de logs e ssl

    • Verificação do .Include selecionados dos arquivos de exemplo

    • Utilização do E2guardian versão 4.1.2

    Caso tenha dificuldades na instalação, reinstalação ou update, verifique na console ou nos logs do sistema que erro está recebendo.

    Se estiver relacionado a permissão, execute:

    chmod 755 /usr/local/etc/e2guardian/ssl
    chmod 755 /var/log/e2guardian
    

    Se estiver recebendo erros de arquivos de configuração faltando ou libs do openssl, tente a reinstalação via console com o parametro -f

    pkg install -f e2guardian
    

    Blz Marcello ja vou realizar o teste no meu ambiente lab que montei…. qualquer coisa reporto.



  • Galera já tenho acompanhado o post desde o inicio, e já fiz alguns teste em VM.
    mas tenho um servidor rodando pfsense,  cujo somente está com squid, mas não funcionando o proxy transparent.
    resumindo…....

    vou colocar o E2guardian e realizar o mesmo procedimento, que fiz na vm e colocar proxy transparente, o que de fato gostaria é de alguma dica sobre como proceder e quais passos devo seguir?
    ate por que amanha pela manha nao conseguirei ir ate o servidor, entao farei tudo remotamente, tenho acesso externo etc, quais dicas ? ou devo limpar algum diretorio ? algo do genero ?

    valeu!



  • O e2guardian não faz ssl transparente, você precisa do squid para isso e em seguida encaminhar para o e2guardian sem habilitar o man in the middle.

    pacote squid configurado modo transparente -> e2guardian -> squid_parent configuração automática.



  • @gambiarraweb1:

    Galera já tenho acompanhado o post desde o inicio, e já fiz alguns teste em VM.
    mas tenho um servidor rodando pfsense,  cujo somente está com squid, mas não funcionando o proxy transparent.
    resumindo…....

    vou colocar o E2guardian e realizar o mesmo procedimento, que fiz na vm e colocar proxy transparente, o que de fato gostaria é de alguma dica sobre como proceder e quais passos devo seguir?
    ate por que amanha pela manha nao conseguirei ir ate o servidor, entao farei tudo remotamente, tenho acesso externo etc, quais dicas ? ou devo limpar algum diretorio ? algo do genero ?

    valeu!

    Dá uma olhadinha pra ver se atende o que tu precisa.

    https://eliasmoraispereira.wordpress.com/2017/06/21/pfsense-proxy-transparente-mitm-no-modo-splice-all-com-squid-e2guardian/



  • Pessoal, estou usando o squid com E2guardian em modo transparente com interceptação de ssl, autenticando por IP  com grupos. Porém mesmo definindo o grupo sempre cai na acl padrão. Como faço para criar  grupos de usuários autenticados por IP? Grato.

    ![Sem título.jpg](/public/imported_attachments/1/Sem título.jpg)
    ![Sem título.jpg_thumb](/public/imported_attachments/1/Sem título.jpg_thumb)
    ![Sem título1.jpg](/public/imported_attachments/1/Sem título1.jpg)
    ![Sem título1.jpg_thumb](/public/imported_attachments/1/Sem título1.jpg_thumb)
    ![Sem título2.jpg](/public/imported_attachments/1/Sem título2.jpg)
    ![Sem título2.jpg_thumb](/public/imported_attachments/1/Sem título2.jpg_thumb)
    ![Sem título3.jpg](/public/imported_attachments/1/Sem título3.jpg)
    ![Sem título3.jpg_thumb](/public/imported_attachments/1/Sem título3.jpg_thumb)



  • Com o squid na frente, você precisa passar o ip do cliente via x-forwarded for.

    No squid marca a opção truncate, no e2guardian, habilite a opção na segunda aba.



  • @vandeir:

    Pessoal, estou usando o squid com E2guardian em modo transparente com interceptação de ssl, autenticando por IP  com grupos. Porém mesmo definindo o grupo sempre cai na acl padrão. Como faço para criar  grupos de usuários autenticados por IP? Grato.

    @marcelloc:

    Com o squid na frente, você precisa passar o ip do cliente via x-forwarded for.

    No squid marca a opção truncate, no e2guardian, habilite a opção na segunda aba.

    Com as informações passadas aqui eu fiz um tutorial básico dessa configuração. Espero que ajude.
    https://eliasmoraispereira.wordpress.com/2017/08/01/pfsense-grupos-com-autenticacao-por-ip-no-squid-e2guardian/



  • Cara, to até emocionado  :'(

    To rodando LISO aqui no modo transparente, autenticando por IP, sem precisar de configurar certificado nem nada.
    Tudo 100% até o momento.

    Obrigado mais uma vez.



  • Marcelloc,

    Coloquei em produção aqui e tá tirando a alegria da galera!!! kkkkkk

    Esta bloqueando legal, mas na aba Real Time > Access Table sempre mostra o IP como 127.0.0.1

    Algum motivo por não estar mostrando o IP correto de acesso?

    Configurei conforme meu tutorial.




  • Bom dia;

    Marcelo tenho instalando e funcionando o seu tutorial juntamento com o bruno do squid e squid guard com o WPAD. Como faço para migrar para o E2guardian e ser feliz?  ;D ;D



  • @empbilly:

    Marcelloc,

    Coloquei em produção aqui e tá tirando a alegria da galera!!! kkkkkk

    Esta bloqueando legal, mas na aba Real Time > Access Table sempre mostra o IP como 127.0.0.1

    Algum motivo por não estar mostrando o IP correto de acesso?

    Configurei conforme meu tutorial.

    Fiz a configuração via grupo como mostro no meu outro tutorial e agora esta mostrando o IP corretamente. :D



  • to tentando instalar, mas fala que o link esta off.. e agora?



  • @empbilly:

    @vandeir:

    Pessoal, estou usando o squid com E2guardian em modo transparente com interceptação de ssl, autenticando por IP  com grupos. Porém mesmo definindo o grupo sempre cai na acl padrão. Como faço para criar  grupos de usuários autenticados por IP? Grato.

    @marcelloc:

    Com o squid na frente, você precisa passar o ip do cliente via x-forwarded for.

    No squid marca a opção truncate, no e2guardian, habilite a opção na segunda aba.

    Com as informações passadas aqui eu fiz um tutorial básico dessa configuração. Espero que ajude.
    https://eliasmoraispereira.wordpress.com/2017/08/01/pfsense-grupos-com-autenticacao-por-ip-no-squid-e2guardian/

    Gostaria de agradecer ao Marcelo e ao empbilly, fiz assim conforme ensinaram e funcionou 100%. Agora vou implementar na empresa que trabalho, um Hospital com 150 usuários, e centenas de acessos e bloqueios diferentes. Obrigado.



  • marcelloc,

    O que significa as entradas abaixo?

    Aug 7 17:46:56	e2guardian	51641	Proxy responded after 1 retrys
    Aug 7 17:46:56	e2guardian	51641	Proxy responded after 2 retrys
    Aug 7 17:46:56	e2guardian	51641	Proxy responded after 2 retrys
    Aug 7 17:46:56	e2guardian	51641	Proxy responded after 2 retrys
    

    Não sei se tem conexão, mas depois de algum tempo não ocorre mais os bloqueios em http. Muito estranho.  :o

    Minha configuração é com squid em modo transparente + Interceptação de SSL.

    Já teve problemas assim?

    EDIT: A memoria também tá sendo extinta. :D



  • Estou tendo um problema para funcionar o Proxy Transparente no modo Split All.

    As vezes vou abrir uma página HTTPS e dá o velho erro de certificado, dou um refresh (uma ou duas vezes) e ele passa.

    @marcelloc
    Estou investigando melhor a situação, mas gostaria de saber se tem algum ambiente funcionando desta maneira 100% ?





  • marcelloc achei um pequeno bug.

    Quando selecionado ACLS / URL lists o Menu Real time some, conforme imagens abaixo.

    Selecionando outras opções da parte de ACLS também acontece isso, menos a opção Site lists.






  • Coloquei na blacklist para bloquear socialnet e movies domains.

    O facebook esta bloqueando, agora o youtube só bloqueia https://youtube.com, porém se colocar https://www.youtube.com ele não bloqueia.



  • @gui.ap:

    Coloquei na blacklist para bloquear socialnet e movies domains.

    O facebook esta bloqueando, agora o youtube só bloqueia https://youtube.com, porém se colocar https://www.youtube.com ele não bloqueia.

    Coloque o youtube como regex.



  • ja fiz e não funcionou.



  • @gui.ap:

    ja fiz e não funcionou.

    Experimenta apagar a cache do squid > Local Cache.



  • Limpei e nada, na regex eu coloquei assim:

    "(^https://www.youtube.com)"->"https://restrict.youtube.com"
    "(^https://m.youtube.com)"->"https://restrict.youtube.com"
    "(^https://youtubei.googleapis.com)"->"https://restrict.youtube.com"
    "(^https://youtube.googleapis.com)"->"https://restrict.youtube.com"
    "(^https://www.youtube-nocookie.com)"->"https://restrict.youtube.com"

    só tirei os comentários # da frente, é isso mesmo?



  • Não. Coloca no final de Acl > URL list > regex

    (youtube)
    

    Ou em site lista

    youtube.com
    

Log in to reply