Router before pfSense suddenly no longer reachable (static and DHCP)

  • Hi there,

    I have a router (Fritz!Box) which is online and provides internet to its Subnet ( Now I wanted to setup a pfSense router as only client in this subnet (because later a second 'external' router which gets internet from an other ISP is planned).
    At first this seemed to work well, pfSense was online and got its IP in the Fritz!Box subnet via DHCP. At that point also the clients in the pfSense network ( were online via the Fritz!Box' ISP.
    Then I tried to change the pfSense IP on the interface which is connected to the Fritz!Box to a static IP ( which is out of the DHCP range as I wanted to disable the Fritz!Box DHCP server in the long run. In the same step I also might have set up a spoofed MAC on that interface but I'm not sure if I maybe did this a little sooner or later.
    However after this point pfSense wasn't able to connect to the Fritz!Box anymore. So simple pings to fail also the routing table is looking good as well as the interface configuration.

    And now I'm not able to get any working connection again, also I really tried a lot:

    • switching back to DHCP -> no luck, IP shows up as in pfSense and pfSense does appear in the Fritz!Box device list, however it has no IP there as well
    • disabling DHCP on the Fritz!Box and using a static connection -> Fritz!Box IP simply not reachable
    • removing all known devices from the Fritz!Box and rebooting the Fritz!Box -> no change
    • rebooting pfSense -> no change
    • changing interface assignments in pfSense -> no change
    • restoring pfSense to a configuration at a time where it guranteed had worked -> no change (however, it looks like the interface still has the spoofed MAC also I'm very sure it wasn't spoofed at that config snapshot)

    If I take the same LAN cable (same Fritz!Box Port) and plug it into a notebook instead of pfSense it instantly works with DHCP as well as a static setup.

    Now I'm really out of ideas.

    So is this some maybe know behaviour or are there any good troubleshooting tips? Also how do I reset the spoofed MACs back to the manufacturer MACs in case this has something to do with it (config backups and setting the field back to blank don't work and the formerly spoofed MACs seem to persist)?

    Thanks for any advice!

Log in to reply