Upgrade 2.3.3-RELEASE-p1 to 2.3.4_1-RELEASE-p1 fails

  • Hey there!

    When trying to upgrade my pfSense 2.3.3 to the latest version the update process fails:

     pfSense-upgrade -c
    >>> Updating repositories metadata... done.
    2.3.4_1 version of pfSense is available
    pfSense-upgrade -d
     <snip>pkg: https://pkg.pfsense.org/pfSense_v2_3_4_amd64-core/All/pfSense-rc-2.3.4.txz: Not Found
    >>> Locking package pfSense-kernel-pfSense... done.</snip>

    (please see attachments for the full log)

    Doesn't matter if the upgrade is started via GUI, #13 in the menu or directly on the shell, the error is the same.

    Accessing the link via browser didn't work either, that gives a DNS error.
    So I've tried to find a solution in the forum, figuring out that the DNS error is no problem since I can resolve the srv records correctly:

    nslookup -type=srv _https._tcp.pkg.pfsense.org
    Non-authoritative answer:
    _https._tcp.pkg.pfsense.org     service = 10 10 443 files01.netgate.com.
    _https._tcp.pkg.pfsense.org     service = 10 10 443 files00.netgate.com.

    I've rebooted the router before running the upgrade and package cache seems to be ok:

     pkg clean
    Nothing to do.

    Any help on further troubleshooting or a solution will be appreciated. :)

  • I had the exact same issue and the following, simple fix resolved it for me:


  • Fixed it for me also.  Looks like it was maybe stuck looking for 2.3.4 and should have been looking for 2.3.4_1?  IIRC older versions would install the upgrade first and then require a second install for the patch…

  • Thanks rwieber and teamits for taking the time to respond :)
    I tried applying the procedure as described, but it didn't work out.. first.
    Now I tried again and it works just fine. I have no idea why it didn't in the first place, the logs showed exactly as before.

    the original problem occured on 2.3.3 -> 2.3.4 as well.
    2.3.4_1 came available while I was trying to update to 2.3.4.

Log in to reply