(SOLVED)NAT Port Forward Rules disabled but able to SSH From WAN to PFsense Box?

  • Hi There,

    First time poster.

    Not sure if this is a bug or intended behavior but maybe someone here can help point me in the right direction.

    I Decided I wanted to SCP something from one of my Linux Hosts while I was out so.  To do this I usually RDP to my main machine and access the webconfigurator.

    I have one NAT PF rule setup to allow me to RDP to this machine (Yes I know I should use the VPN Access server but my hardware does not handle it that well) and that is all.

    I begin to set up a NAT PF rule to allow me SSH access from WAN to my Linux Host but connection is refused.  No mater how many times or ways I tried to Create the rule it would not connect so I disable the rule.

    At this point instead of trying the Destination port I selected for the heck of it I try good old port 22.  To my surprise it opens a SSH connection using my public IP over Port 22.  I then check the NAT PF rules and yes its disabled.

    I go to the Advance Settings and disable SSH access to the PFsense box and try again….

    No connection, ok good.

    I re-enable SSH access to the PFsense box and again I am able to access the PFsense box from my public ip over WAN.

    Obviously this is unwanted so I currently have SSH access disabled.

    Please can someone tell me, is this the intended behavior or is this a bug I should file?

    Any thoughts would be appreciated!


    EDIT:  Not sure what was creating this behavior. Seems to have stopped...

  • LAYER 8 Global Moderator

    What are you wan rules?  Post them!  Unless you have wan rule that allows the access creating a port forward does ZERO!

Log in to reply