Is there a way to trace which port is blocked when playing PS4 game?

  • @warheat1990:

    I'm playing Bloodborne right now after a long break and I notice that I can't get online anymore (other game is working fine by the way), the game will kick me out as soon as I start, it's working fine when I used my OpenWRT router but not pfsense.

    I set my PS4 with static IP and put it in UPnP, my setup is as follows.

    allow 1024-65535 80-65535 <– this is my PS4 static IP

    I also tried manually open ports used by PSN and Bloodborne based on this tutorial but still no luck.

    Is there a way to debug this issue?

  • What is your WAN of you pfsense plugged into?

  • @kejianshi:

    What is your WAN of you pfsense plugged into?

    Router modem from ISP in bridge mode.

  • LAYER 8 Global Moderator

    I find it just moronic that 80/443 would be needed inbound..  For starters many ISP block this, because their users are not suppose to run servers, etc.

    What is needed in the gaming community is simple straight forward, is the traffic needed inbound (port forward) or is it needed to be allowed outbound.  Its should also be a given in the home setup that all ports are allowed outbound at the router.  Ie default any any, etc.  Also for your port forwards which if any should be static.. Ie the source port can not be changed like what happens with NAPT on any soho router.

    If your going to be using UPnP then you shouldn't need to port forward anything.  And you should be able to see the requests for ports, etc.  If you really do need 80/443 inbound - your going to want to make sure pfsense is not listening on those for its gui, etc.

    simple netstat -an will tell you what ports pfsense listening on.

    As to finding what is not open.  This should be logged in the firewall as a block into your wan.  Unless you had turned off default logging, etc.  You could also sniff at the wan if you wanted too, etc.

  • Router modem from ISP in bridge mode…

    Dumb question, I know.  Kill me later.  What is your pfsense WAN address?  Public?  (Yes - I know it should be)

    If your bridge is working correctly, and if you are of the mind to experiment...  Try static outbound NAT for the ports used by your PS4.

  • LAYER 8 Global Moderator

    BTW this allow statement wouldn't actually work if you need 80/443 inbound..

    "allow 1024-65535 80-65535"

    Your saying in that rule that external you can forward ports 1024+ to internal 80+ so how could 80 or 443 actually be forwarded inbound?  You could only request a redirect from say 1024 to 80.. Which would the game work that way?  If it really needs 80 and 443 open inbound?

    I still find it unlikely games would need 80 inbound.  Also from your link - how is this clear?

    The opening of the port Port required to connect to the PSN, is as following each port is required for online play of "Bloodborne". Please to open the port if such can be well connected in the network equipment you are using.

    ■ port number required to connect to the PSN TCP: 80,443,3478,3479,3480 UDP: 3478,3479

    Port number required to online play of ■ "Bloodborne" TCP: 18671, 20443 UDP: 9305,9306

    It doesn't state if those are need to be allowed outbound or inbound..  Lets look at your port 3478 for example… This port is typically the OUTBOUND Port from your network to the STUN server.. It would not be needed inbound unless you were running a STUN server behind your NAT..

    To be honest the best way to get this to work would be to let UPnP do its thing.. And then watching what ports get opened in via UPnP you could always switch that to manual port forwards, etc.

    My son never complained when he had his PS online.. All I ever did was turn on UPnP for his PS IP with the 1024+ restrictions both external and internal.  The only thing that could request UPnP was his PS, and it was locked to its own vlan (UPnP was only listening on this vlan interface on pfsense).  He no longer lives at home, so sorry I can not be of more help with actual testing since I do not have a PS to test with.

  • Blast from the past right?

    So, that solution from before was a combination of upnp turned on and setting up some static outbound NAT.

    If this doesn't work for you, hitting your ISPs combo router / modem with a large hammer may help in the long run.

  • LAYER 8 Global Moderator

    Setting all Ports as static is BORKED!!!  That is for sure..  NAPT can not function with multiple devices behind it with all ports being static.. Since what happens when client A wants to use source port X and client B also tries to use source port X..

    That is not a valid solution in the long run with multiple clients using the same public IP.. Sooner or latter your going to run into conflicts NAPT not being able to do its thing if you tell it that all source ports need to be static..

    The correct solution to such a problem with ps4 needing some source ports be static is to set those specific outbound ports as static..  Not all ports ;)

  • Ohhhhhh yeah.  I agree.  turn on upnp and set static outbound on the specific ports you need and forward those ports for good measure.

    I don't see any problem with static nat applied to an interface with a single client though, in terms of breaking other things.

Log in to reply