Squid package on 1.2.1 and 1.2.2



  • I am currently running it on rc4 without any problem. No crashes, exept one when swap.state suddenly took up 100% of the disc.



  • @mkuron:

    Already tried reinstalling squid several times. My next step would be to try squid3 - does squidguard work with squid3?

    I install squid 3 at this monday - problems with SG not found (maybe at next time)



  • Very odd - squid3 is also crashing on me with the exact same errors:

    Dec 18 18:04:53 squid[3791]: Exiting due to repeated, frequent failures
    Dec 18 18:04:53 squid[3791]: Squid Parent: child process 4221 exited with status 1
    Dec 18 18:04:53 (squid): The dnsserver helpers are crashing too rapidly, need help!
    Dec 18 18:04:53 squid[3791]: Squid Parent: child process 4221 started
    Dec 18 18:04:50 squid[3791]: Squid Parent: child process 4110 exited with status 1
    Dec 18 18:04:50 (squid): The dnsserver helpers are crashing too rapidly, need help!
    Dec 18 18:04:49 squid[3791]: Squid Parent: child process 4110 started
    Dec 18 18:04:47 check_reload_status: reloading filter
    Dec 18 18:04:46 squid[3791]: Squid Parent: child process 3982 exited with status 1
    Dec 18 18:04:46 (squid): The dnsserver helpers are crashing too rapidly, need help!
    Dec 18 18:04:46 squid[3791]: Squid Parent: child process 3982 started
    Dec 18 18:04:43 squid[3791]: Squid Parent: child process 3952 exited with status 1
    Dec 18 18:04:43 (squid): The dnsserver helpers are crashing too rapidly, need help!
    Dec 18 18:04:43 squid[3791]: Squid Parent: child process 3952 started
    Dec 18 18:04:40 squid[3791]: Squid Parent: child process 3794 exited with status 1
    Dec 18 18:04:40 (squid): The dnsserver helpers are crashing too rapidly, need help!
    Dec 18 18:04:40 php: /pkg_mgr_install.php: Reloading Squid for configuration sync
    Dec 18 18:04:39 check_reload_status: reloading filter
    Dec 18 18:04:39 squid[3791]: Squid Parent: child process 3794 started
    Dec 18 18:04:39 php: /pkg_mgr_install.php: Reloading Squid for configuration sync
    Dec 18 18:04:39 php: /pkg_mgr_install.php: Starting a proxy monitor script
    Dec 18 18:04:39 php: /pkg_mgr_install.php: Starting Squid
    Dec 18 18:04:38 php: /pkg_mgr_install.php: Stopping any running proxy monitors
    Dec 18 18:04:06 php: /pkg_mgr_install.php: Beginning package installation for squid3.



  • I just reinstalled pfSense 1.2.1-RC4 (I had to first install 1.2-RELEASE because my server won't boot the pfSense 1.2.1-RC4 CD).
    Same problem, dnsserver still dies rapidly, both on squid and squid3.

    Anyway, why is the squid package compiled with the –disable-internal-dns option? The squid developers no longer recommend it (neither on 2.6 nor on 3.0) and I don't see a real reason for it.



  • Maybe you use TinyDNS package ?



  • No, I don't. I currently have a clean install of 1.2.1-RC4 with the squid package installed, nothing else.
    And I highly doubt installing tinydns would solve any problem. squid's dnsserver performs DNS lookups for Squid.



  • Type cmd from shell
    squid -d10
    What log will be displayed ?



  • 2008/12/18 20:12:06| Starting Squid Cache version 2.6.STABLE21 for i386-portbld-freebsd7.0…

    2008/12/18 20:12:06| Process ID 15050
    2008/12/18 20:12:06| With 11072 file descriptors available
    2008/12/18 20:12:06| Using kqueue for the IO loop
    2008/12/18 20:12:06| Performing DNS Tests...
    2008/12/18 20:12:06| Successful DNS name lookup tests...
    2008/12/18 20:12:06| helperOpenServers: Starting 5 'dnsserver' processes
    2008/12/18 20:12:06| User-Agent logging is disabled.
    2008/12/18 20:12:06| Referer logging is disabled.
    2008/12/18 20:12:06| Unlinkd pipe opened on FD 15
    2008/12/18 20:12:06| Swap maxSize 102400 + 8192 KB, estimated 0 objects
    2008/12/18 20:12:06| Target number of buckets: 425
    2008/12/18 20:12:06| Using 8192 Store buckets
    2008/12/18 20:12:06| Max Mem  size: 8192 KB
    2008/12/18 20:12:06| Max Swap size: 102400 KB
    2008/12/18 20:12:06| Store logging disabled
    2008/12/18 20:12:06| Rebuilding storage in /var/squid/cache (DIRTY)
    2008/12/18 20:12:06| Using Least Load store dir selection
    2008/12/18 20:12:06| Current Directory is /usr/local/libexec/squid
    2008/12/18 20:12:06| Loaded Icons.
    2008/12/18 20:12:06| Accepting proxy HTTP connections at 192.168.16.1, port 3128, FD 17.
    2008/12/18 20:12:06| Accepting HTCP messages on port 4827, FD 18.
    2008/12/18 20:12:06| WCCP Disabled.
    2008/12/18 20:12:06| Pinger socket opened on FD 20
    2008/12/18 20:12:06| Ready to serve requests.
    2008/12/18 20:12:06| WARNING: dnsserver #1 (FD 6) exited
    2008/12/18 20:12:06| WARNING: dnsserver #2 (FD 7) exited
    2008/12/18 20:12:06| WARNING: dnsserver #3 (FD 8) exited
    2008/12/18 20:12:06| Too few dnsserver processes are running
    FATAL: The dnsserver helpers are crashing too rapidly, need help!

    Everything looks right, except for the _dnsserver_s crashing.



  • Hm, maybe permissions … no more ideas  :-
    Try search google or yahoo for this problem.



  • Google has exactly five results, none of them relevant to this issue. Seems like I'm the only person having it?



  • Call from shell
    echo pfsense.com | /usr/local/libexec/squid/dnsserver

    Check permissions /usr/local/libexec/squid/dnsserver
    root 0555



  • The permissions on dnsserver are correct:

    -r-xr-xr-x  1 root  wheel  6528 Jul 24 04:10 /usr/local/libexec/squid/dnsserver

    dnsserver also works correctly:

    $addr 0 69.64.6.21



  • I just downloaded the VMWare image of 1.2.1-RC4 and squid works like a charm.
    My guess is that during the upgrade from 1.2-RELEASE to 1.2.1-RC4, something happens that prevents squid from running correctly.

    Unfortunately, I cannot install 1.2.1-RC4 directly on my HP NetServer LH3000 because for some reason, it won't boot from that CD. However, I will try installing it in VMWare and then cloning it to the server's hard drive.



  • I just did a clean install of 1.2.2 (via PXE boot) into VMWare and I'm getting the exact same "The dnsserver helpers are crashing too rapidly, need help!" error after installing squid 2.6.



  • I'm having issues here too.  I just got around to tinkering with 1.2.2 tonight.  I too had issues getting things going but I restored a config and let the packages install upon reboot.  That was a mess, so I uninstalled all, then tried squid3.  It crashed, but once I went through the config pages and hit save I was able to get it up and running.

    I was not, however, able to get the transparent proxy to work.  If I setup my browser manually, I was subjected to all the rules as expected.  When I try via transparent, nothing goes through the proxy, and nothing gets logged.

    Squid 2.6.21_07 seems to be working as expected.



  • Interesting.. I'm using 2.0 alpha and am having the same issue.  Of course after running fine for a few days, I head out of town on business and the Mrs. calls saying the net down, after troubleshooting, I'm getting the same error.  Anyone have a clue why?



  • I solved this crash when i recreated the cache

    drop to pfsense shell

    cd /var/squid/cache
    rm -Rf *
    /usr/local/sbin/squid -z
    wait the prompt return

    goto the web GUI and hit save button on proxy



  • Seems like the problem is gone in pfSense 1.2.2 and/or squid 2.6.21_07.

    I just installed pfSense 1.2.2 from CD onto a HP xw6000 and it worked like a charm.
    I suspect the problem I had before may not even have been related to pfSense or the squid package, but to some permissions issue due to the way I installed pfSense via PXE/NFS.



  • I installed squid+squidguard in pfsense 1.2.2 just to get rid of file extensions. The main purpose is to block the downloads like .exe .avi .. So its working. But how to set squid+squidguard not to log anything? I dont want them to be saved in the Hardisk… I dont have enough space.. I want it just blocking .exe and avi ... thanks

    jigp
    davao city



  • Uncheck the box called 'Enabled Logging' in the Services/Proxy Server GUI.



  • Thanks i got it already. Thanks for the heads up :)
    Jigp
    Davao City



  • im still have issue with squid 3 + squidguard ….
    squid is work ... but
    squid guard not work with squid 3 ...
    is there have succes with squid 3 + squidguard ?
    i would like to use squid 3 + squid guard cause i have new machine
    production machine still give to 1.22 stable

    btw ... no problem at all with squid 2 + squidguard
    even that with 1.2.2, 1.2.3 rc2
    not try yet with 2.0 alpha ...

    thanks for feedback
    pfsense ... rock solid :D



  • 1.2.2 squid looks good. Except squid3 it wont work on 1.2.2.. Not sure to others..


Log in to reply