Pacote não oficial E2guardian v5 para software pfsense®



  • @marcelloc Blz...Quando será lançada ? Outra duvida como faço para personalizar esse portal nativo do userauth?



  • @maicosantana teremos uma nova versão lançada (com integração do UserAuth com o Squid3/4 também) na próxima semana.

    ;-)

    Fique atento ao changelog da ferramenta: https://www.conexti.com.br/changelog-userauth

    Abraços!
    Jack



  • E2guardian bloqueando todos os sites apos atualização do mesmo:

    @marcelloc boa noite, o que vou relatar não ocorreu so comigo, também com outros companheiros de um grupo do Pfsense a qual faço parte.
    O que ocorre é que saiu uma atualização do E2guardian e fizemos (eu pelo menos fiz somente em um dos meus PF), depois da atualização simplesmente qualquer site que tentasse navegar simplesmente é bloqueado, não importa se todas as ACLS esteja com a função interna desmarcada (que era para tudo funcionar), mesmo assim não navega nada.
    Não é problema com regras do PF e nem nada chequei tudo e estava tudo do mesmo jeito que estava antes da atualização, tudo funcionava bem, meu PFS é a versão mais atual.
    Mais alguém passou por isso?? Como podemos resolver??

    Desde ja gradeço.



  • @lotus, salvou e aplicou as configurações depois de atualizar?
    Em todos os ambientes que atualizei, até agora não encontrei esse problema.



  • Eu tbm atualizei e notei problemas com site http mesmo colocando em white list ele barra continua bloqueando



  • @marcelloc sim fiz isso que você sitou, inclusive removi o pacote e todos os seus arquivos que sobraram, reiniciei e instalei do zero e mesmo assim continuou bloqueando a navegação, no realtime aparece tudo sendo bloqueado. Como sitei antes outros colegas de grupos de PF também tiveram o mesmo problema.



  • @lotus bom dia.

    Vi várias mensagens e resolvi testar em meu ambiente, não tive o problema que você está enfrentando. Não seria problema com a blacklist que está utilizando?
    0_1552564754259_6cf547d3-db1f-4b86-b179-9247f6e7ffab-image.png

    0_1552564819969_879d2289-921c-4695-9d61-42fd88585695-image.png



  • @lotus o que mostra o log, qual é o código? para ter mais detalhes mude para o formato do e2guardian.



  • @victorfmaraujo não mano, não é problema com blacklist pq é a mesma shallaslist que ele usa, não foi alterada. So vou poder fazer uma investigação mais profunda no sábado que é o dia que a clinica para, pq durante o dia é complicado mexer por la pq esta em produção. Assim que tiver a resposta da bronca eu aviso.



  • @tomaswaldow como removi tudo dele vou tentar encontrar alguma coisa e coloco aqui para ser analisado.



  • @lotus said in Pacote não oficial E2guardian v5 para software pfsense®:

    E2guardian bloqueando todos os sites apos atualização do mesmo:

    Bom meus amigos baixo as informações para tentarmos entender o que aconteceu depois da atualização ou mesmo instalando do zero removendo todo o resto de arquivo existente, o e2guardian continua a bloquear todo e qualquer site que tentar navegar.

    Log das estações:

    0_1552618588941_Captura de tela de 2019-03-14 23-53-58.png

    Log do sistema:

    0_1552618656585_Captura de tela de 2019-03-14 23-54-16.png

    Log do sistema:

    0_1552618709315_Captura de tela de 2019-03-14 23-54-23.png



  • Muda o log para o formato e2guardian. Vai receber mais detalhes do problema.

    Quando tenta dar um reload via console, recebe alguma mensagem de erro de configuração?



  • @marcelloc aparece isso:

    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list addheader used at line 32 of /usr/local/etc/e2guardian/common.story
    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list override used at line 33 of /usr/local/etc/e2guardian/common.story
    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list addheader used at line 72 of /usr/local/etc/e2guardian/common.story
    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list override used at line 73 of /usr/local/etc/e2guardian/common.story
    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list exceptionuseragent used at line 138 of /usr/local/etc/e2guardian/common.story
    SB warning: Undefined list /usr/local/etc/e2guardian/g_Default.story list exceptionuseragent used at line 145 of /usr/local/etc/e2guardian/common.story
    
    Error reading file /usr/local/etc/e2guardian/lists/blacklists/adv/domains: No such file or directory
    Error opening file: /usr/local/etc/e2guardian/lists/blacklists/adv/domains
    Error reading: /usr/local/etc/e2guardian/lists/bannedsitelist.g_Administrativo
    Error opening banned
    Error reading file /usr/local/etc/e2guardian/lists/blacklists/adv/urls: No such file or directory
    Error opening file: /usr/local/etc/e2guardian/lists/blacklists/adv/urls
    Error reading: /usr/local/etc/e2guardian/lists/bannedurllist.g_Administrativo
    Error opening banned
    

    acho que ja sei onde esta o problema, mas para corrigi-lo preciso zerar toda e qualquer configuração do e2guardian que o sistema possa ter. Acho que é isso que esta causando isso tudo. Como zero isso, tipo reseto ele e começo a configurar novamente?



  • @lotus, o problema está na blacklist. Tenta aplicar ela novamente e ve se o erro some.
    Se não sumir, contorne criando as pastas e arquivos que o e2guardian está procurando.

    Os warnings não precisa se preocupar, foca somente nos erros.



  • @marcelloc blz ja estou trabalhando nisso!



  • @marcelloc isso pode ser problema com permissão?? o arquivo esta la, existe! esta tudo la mas mesmo assim ele diz que não existe.

    Mar 15 00:20:18	e2guardian	26597	Unable to read /usr/local/etc/e2guardian/lists/bannedsitelist.g_Default
    Mar 15 00:20:18	e2guardian	26597	Error reading /usr/local/etc/e2guardian/lists/blacklists/aggressive/urls. Check directory and file permissions. They should be 640 and 750: No such file or directory
    Mar 15 00:20:18	e2guardian	26597	Error reading file /usr/local/etc/e2guardian/lists/blacklists/aggressive/urls: No such file or directory
    Mar 15 00:20:18	e2guardian	26597	Error opening file: /usr/local/etc/e2guardian/lists/blacklists/aggressive/urls
    Mar 15 00:20:18	e2guardian	26597	Error reading file: /usr/local/etc/e2guardian/lists/bannedurllist.g_Default
    Mar 15 00:20:18	e2guardian	26597	Error opening banned
    Mar 15 00:20:18	e2guardian	26597	Unable to read /usr/local/etc/e2guardian/lists/bannedurllist.g_Default
    Mar 15 00:20:18	e2guardian	26597	Error reading /usr/local/etc/e2guardian/lists/blacklists/aggressive/domains. Check directory and file permissions. They should be 640 and 750: No such file or directory
    


  • @lotus pode me dizer como está a configuração do seu parent na aba general - Advanced Features?



  • @victorfmaraujo basicamente isso tudo que tenho, não creio que seja esse o problema levando em conta que nada foi alterado.

    0_1552706743649_Captura de tela de 2019-03-16 00-23-48.png



  • @lotus faltou a configuração que pedi, verifique se está em DIRECT Connect.



  • ola pessoal, já faz um tempo que não estou usando e2guardian pelo fato de estar usando 2 links e o e2guardian não reconhecer o loadbalance, queria saber se depois das atualizações já existe alguma solução pra isso? vou ter que implementar o proxy em meu ambiente de qualquer jeito, alguém já encontrou alguma solução pra usar com load balance ? ou so usando o squid como proxy parent com a opção de AclRandom, essa não é uma opção muito boa para mim.



  • Não estou conseguindo configurar o e2guardian5 com o squid, como faço isso de forma correta? o squid esta funcionando, consigo bloquear direto nas acls dele, mas o e2guardian não bloqueia nada e como se ele não enxergasse o squid.



  • Pessoal boa tarde!!!

    Depois de muito tentar, conseguir instalar o E2guardian e até agora está bloqueando tudo, tudo mesmo!!!

    Porém estou com alguns problemas e dúvidas e gostaria da ajuda de vocês.

    Como funciona a questão das Acls, Groups e IP? Tento me basear em relação ao squidguardian mas não está dando muito certo. Fico confuso em relação as acls. qual sequencia eles seguem.

    Quando coloco algum ip ou aliases no Bypass Proxy for These Destination IPs, eles ainda pegar o certificado ou não? Estou com um problema em relação ao bradesco. Eles usando um aplicativo para acesso a conta PJ, quando o ip do computador não está "liberado do e2guardian" o navegador não consegue acessar o site e fica dando erro de certificado. Alguém conseguir resolver essa bronca?

    Valeu galera



  • @babingthon

    Vc chegou a acompanhar o video sobre a configuração básica do pacote?

    Se não viu, por favor, veja aqui primeiro: https://youtu.be/rHmvAtt5Ybw

    Abraços!
    Jack



  • @JackL

    eu vi o video sim, foi por ele que eu realizei as configurações iniciais.

    as minhas dúvidas são mais especificas.

    obg



  • @joancefet em System / Routing / Gateways estou deixando Automatic, já observei que quando um link cai o outro é acionado, porém as regras de trafego para bancos (tenho um link da NET e outro ALGAR), tendem a ficar lentos



  • @babingthon bom dia amigo, blz?
    Vc pode na aba Real Time acompanhar o acesso e verificar os IP's que estão sendo bloqueados e criar um ALIAS para então liberar no By Pass do E2Guardians.

    Outro caminho que pode seguir, é verificar no site https://bgp.he.net/ inserir o nome do banco e ele carrega os IP's utilizados.
    Forte abraço!



  • Boa tarde, será que alguém poderia me dar uma ajuda?!?

    Seguinte, tenho um pfsense que atualizei pro 2.4.4.

    Antes de fazer a atualização, eu usava o squid e filtrava alguns sites, mas parou de funcionar e eu não encontrava a solução. Resolvi atualizar.

    Pois bem, após atualizar não funcionou também, então decidi partir pro E2guardian.

    Assisti o tutorial de instalação e fiz como está no tutorial, bem básico msm, mas não está funcionando. Não consigo bloquear nada.

    Mais detalhes:

    • Removi o pacote do squid.
    • Uso duas WAN, criei um grupo de Gateway e chamei de LB, e com isso meus dois links são usados simultaneamente pra navegar na internet.


  • @Eric_Barbosa Se puder Postar suas Configurações sera melhor provavelmente algum detalhe foi esquecido, mas de antemão verifique no e2guardian na aba tempo real se esta aparecendo o trafego.



  • @MRamon Obrigado pela ajuda.
    Sim, consigo ver todo o tráfego na aba "Real Time". Repassei as configs passo a passo com o tutorial.

    • interfaces (LAN E LOOPBACK)
    • porta (8080)
    • Allow users on interface (ticado)
    • Http workers (256)
    • Transparent http proxy (ticado)
    • Proxy interfaces (LAN)
    • Bypass Proxy for Private Address Destination (ticado)
    • Parent mode (Direct connect)
    • Watchdog (ticado)
    • Auth Plugins (Ip Address)
    • Scan Options (Scan clean cache, Create list cache files (on), deletedownloadtempfiles(on)
    • ACLs e Grupos, igual o tutorial tbm

    Tentei colocar o domínio de sites na ACL default, pra testar, e msm assim não bloqueia.



  • @Eric_Barbosa Em Daemon enable ssl suporte esta ativo?Dentro da acls default em baned -> include selecionou as categorias?
    Vai em acl->Site Lists-> entra na acl default Baned->Include e seleciona socialnet domains e verifica se facebook esta bloqueando, acesse o facebook vai em real time verfica se esta aparecendo o ip da sua a maquina e o estado bloqueado ou não, vai ter que aparecer o teu acesso la como bloqueado ou não.

    Verificar tambem se o bloqueio não esta acontecendo apenas em paginas http



  • @MRamon Bom dia, o "ssl suporte" realmente não estava ativo. Estava filtrando só sites http mesmo, mudei isso.

    Bom, fiz o que sugeriu, mas não está aparecendo o ip do meu pc em "Real Time". Além disso, vários sites foram bloqueados, como google, globo.com, uol, .. Mesmo eu só tendo escolhido pra bloquear as redes sociais.

    Bom, continuo testando.



  • @Eric_Barbosa Entendi, esses bloqueios indesejados são causados provavelmente pelas configurações que você fez em Groups( certifique-se de não estar selecionado a opção Filter ssl sites forging SSL certificates pois com essa opção tem que estar com certificado da CA na maquina para navegar), meu conselho não siga totalmente as configurações do vídeo do marcelloc quando eu sequi as configurações do video eu tive os mesmos "problemas" bloqueio do google do gmail entre outros sites isso se da devido ao poder do e2guardian, se não estou enganado no video ele altera umas configurações nos grupos colocando uma especie de pontuação para phrase bloqueadas alguma coisa nesse sentido, acho que é isso e que causa esses bloqueios, eu deixo tudo mais padrão nos groups que crio, apenas seleciono as acls o template HTML da tela de bloqueio e as Group Options e assim agora tudo funciona bem pra mim, essas outras opções e melhor ir testando depois, com essas opções consegui uma vez fazer o bloqueio ate de palavras na pesquisa de Google mas as vezes bloqueava toda a pesquisa.



  • @MRamon Olá, bom dia. Primeiramente obrigado pela ajuda, consegui fazer funcionar e agora está funcionando bem. Após parar pra refletir um pouco mais, e dar uma revisada, percebi que estava com a porta 8081 bloqueada, por isso quando eu ativava a ACL, toda a navegação interceptada ficava bloqueada. No momento, está tudo funcionando bem.



  • @Eric_Barbosa Eu nunca usei essa Exception Ip List, para não filtrar trafego de alguns ips ou eu dou bypass ou eu crio grupos com os ips que não quero filtrar e em group type coloco a o opção Unfiltered Access- Allow access to any sites todos os que estiverem incluídos nesse grupo não serão filtrados mas você tera todo o historico de navegação registrado no e2guardian. Agora se você quiser que alguns hosts não passem pelo proxy ou seja dar bypass nesses ips vai em firewall ->Aliases-Crie um Aliase com os ips que você não quer que passe pelo proxy exemplo:Diretoria, vai no e2guardian na aba Daemon->Tranparent Proxy Settings->Bypass Proxy for These Source IPs coloque o Aliase ou varios aliases separados por ponto e virgula pode colocar ips tambem, exemplo: Diretotia;gerencia_geral;192.168.1.12, tudo que for colocado aqui não vai passar pelo proxy sem bloqueio sem registro da navegação;



  • @MRamon Boa tarde,
    Por gentileza poderia me dizer se está correto assim:

    em alias na parte de ip eu crio com o nome:
    ipsliberados

    dentro dele eu cadastro assim:
    189.3.234.XX
    caixa.com.br

    depois boto onde você falou com o nome:
    ipsliberados

    seria essa a sequencia?

    Obs. estou cadastrando o www.caixa.com.br usando o e2guardian com wpad e não abre.



  • @lucianosaulo as redes da Caixa são: 200.201.160.0/20, 200.201.172.0/22



  • Alguém já passou por isso? Alguém sabe como resolver?

    Meu e2guardian esta rodando normalmente. Minhas configurações são com o squid fazendo a autenticação no AD e o e2guardian responsável pelos bloqueios. No e2guardian, no menu "Users" esta perdendo as configurações, ficando em branco...

    Por exemplo: ontem adicionei todos os usuários que devem fazer parte de tal grupo, hoje minha lista apareceu em branco. Já não é a primeira vez que isto ocorre.



  • @Lucayan said in Pacote não oficial E2guardian v5 para software pfsense®:

    Alguém já passou por isso? Alguém sabe como resolver?

    Meu e2guardian esta rodando normalmente. Minhas configurações são com o squid fazendo a autenticação no AD e o e2guardian responsável pelos bloqueios. No e2guardian, no menu "Users" esta perdendo as configurações, ficando em branco...

    Por exemplo: ontem adicionei todos os usuários que devem fazer parte de tal grupo, hoje minha lista apareceu em branco. Já não é a primeira vez que isto ocorre.

    Está com a integração LDAP no e2guardian configurada ou tem algum outro pfSense que possa estar replicando para este fw onde está o e2guardian?

    Fora estes dois casos, não vejo como a configuração possa estar apagando.

    Veja também se nos logs tem algum alerta de restore de configuração.



  • Bom dia .. alguem tendo problema com PFBLOCK NG junto cm e2quardian ?
    o meu si reinicio o servidor a internet para de funcionar, é preciso parar o pfblock e iniciar novamente para funcionar a internet.



  • Feedback

    @marcelloc - Marcello, Boa tarde. A título de feedback, notei um problema na versão do e2guardian5.3.2 - Após instalado e funcionando, o firewall não dá mais reboot/halt.
    Quando roda o script de "stop" ele acaba ficando preso no"waiting" do PID. Veja detalhes abaixo:
    -->/bin/sh /usr/local/etc/rc.d/e2guardian.sh stop
    kern.ipc.somaxconn: 16384 -> 16384
    kern.maxfiles: 131072 -> 131072
    kern.maxfilesperproc: 104856 -> 104856
    kern.threads.max_threads_per_proc: 20480 -> 20480
    Stopping e2guardian.
    Waiting for PIDS: 59345

    Depois disto, só matando a task com "kill" - ai o processo de reboot/halt segue em frente.
    Testei com e sem o "watchdog" ligado. O resultado é o mesmo.
    Não é problema no pkg da GUI, pois eu testei com a 5.3.1 e 5.3.2, o resultado também é o mesmo. O problema vem do e2guardian mesmo.
    Já na versão 5.3.1 isto não acontece. o Script de Stop funciona normalmente. Fiz os testes com o pacote do E2guardian instalado apenas, nada mais. Sendo assim, descartei o conflito com qualquer outro pacote.

    Abraço

    Fabricio.


Log in to reply