Pacote não oficial E2guardian v5 para software pfsense®



  • @raffaD11 Estou também com o mesmo problema e não consigo instalar o e2Guardian no pfSense 2.4.4 de jeito nenhum. Alguém já sabe como resolver?

    Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/e2guardian.inc:77
    Stack trace:
    #0 /usr/local/pkg/e2guardian.inc(677): e2g_check_sched('Always active')
    #1 /usr/local/pkg/e2guardian.inc(2056): sync_package_e2guardian('no', true)
    #2 /etc/inc/pkg-utils.inc(770) : eval()'d code(3): e2guardian_php_install_command(false, true)
    #3 /etc/inc/pkg-utils.inc(770): eval()
    #4 /etc/inc/pkg-utils.inc(858): eval_once('update_status("...')
    #5 /etc/rc.packages(74): install_package_xml('E2guardian5')
    #6 {main}
    thrown in /usr/local/pkg/e2guardian.inc on line 77



  • @marcelloc Boa tarde Marcelo!
    Teria como você me ajudar a resolver este problema no meu 2.4.4-RELEASE-p3 (amd64)? Eu tento instalar o pacote e dá este erro. Já criei o patch extra oficial como manda no seu vídeo... Tenho visto que é um erro comum. Veja:

    PHP errors
    PHP ERROR: Type: 1, File: /usr/local/pkg/e2guardian.inc, Line: 77, Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/e2guardian.inc:77
    Stack trace:
    #0 /usr/local/pkg/e2guardian.inc(677): e2g_check_sched('Always active')
    #1 /usr/local/pkg/e2guardian.inc(2056): sync_package_e2guardian('no', true)
    #2 /etc/inc/pkg-utils.inc(770) : eval()'d code(3): e2guardian_php_install_command(false, true)
    #3 /etc/inc/pkg-utils.inc(770): eval()
    #4 /etc/inc/pkg-utils.inc(858): eval_once('update_status("...')
    #5 /etc/rc.packages(74): install_package_xml('E2guardian5')
    #6 {main}
    thrown @ 2020-02-19 17:39:46



  • @alexfabian ,

    Veja como instalar os repos extras: https://youtu.be/i_FjN6o_6CQ

    Abraços!
    Jack



  • Fala moçada blza ? estou com um problema aqui, meu e2guardian é configurado para bloquear todos os sites, menos os que eu libero... está tudo funcionando perfeito menos o youtube. o youtube continua acessando normalmente mesmo ele não estando na lista para liberar... vou na opção para monitorar o acesso em tempo real, e quando digito youtube no navegador, no monitoramento me retorna links como esses:

    ezguard.png

    Alguem tem uma luz ?



  • Olá pessoal! Tudo bem?

    Meu e2guardian parou de gerar log. o arquivo access.log está vazios, o comando tail -f /var/log/e2guardian/access.log não exibe nada, o e2g nao está enviando dados para o log. Estava funcionando até 3 dias atrás.
    Por onde devo começar a procurar a solução do problema?



  • @maicosantana No E2Guardians eu inseri na guia ACL, Exception os endereços abaixo;
    whatsapp.com
    31.13.67.52
    2a03:2880:f22c:c5:face:b00c::167
    mmx-ds.cdn.whatsapp.net



  • This post is deleted!

Log in to reply