New SM A1Sri-2758f build -> inconsistent speeds on gigabit downlink

  • Hi all,

    First - I will preface by saying that I spent considerable time researching my issue on the forums and unfortunately, can't come across a resolution. Cliff notes as following:

    • Recently acquired Comcast Xfinity gigabit service; have my own DOCSIS 3.1 Arris modem.

    • Upgraded from a D525 based Atom system to an shiny A1SRi-2758f with 4GB of ECC RAM and 30 gig SSD.

    • Restored from a pre-existing backup; modified interfaces before loading the backup and aside from a minor OpenVPN issue - no problems.

    • I have pfBlockerNG and Snort running; I do understand these will impact speeds.

    At this point - I am experiencing very inconsistent results which are mind boggling:

    • Download speeds are ranging between 450 mbit and 900 mbit (once! I hit 900 once!), but seem to be hovering around 600 mbit. This was tested via speedtest, via static file downloading, via usenet and via Steam (where I got the highest consistent speed of 800 mbit). Upload is stable at a meager 40 mbit (thanks, Comcast!)

    • Testing using iperf3 within my LAN yields ~480 mbit, no more, between the pfSense box and a local server. On the same switch, testing between two other machines maxes out the connection - so it's definitely not the switch. I have not ruled out the network cable, though - so that will be tested next but for the moment, lets assume it is fine.

    • PowerD is enabled; tried setting it to Adaptive, HiAdaptive, Maximum - no change.

    • Hardware checksum offload, hardware TCP segmentation offload and hardware large receive offload are disabled.

    • MTU is at default levels (not sure what values I should play with here).

    • Attempted to kill snort - to no avail.

    So there I am! There is another thing I am going to try - disable Special C1E states in the BIOS - but I don't see how that would affect anything unless FreeBSD throttles the proc down significantly due to that.

    Any other suggestions? Anyone with this board experiencing (or experienced) these kinds of issues?


  • Update:

    Solved my own problem!

    Enhanced C1E should remain disabled - once I turned that off, along with ACPI 3.0 T-states, full blast ahead you go! I am at about 920 mbit which I can live with.

    Cheers :)