SG-1000 performance

  • Connected to my ISP via an ASUS RT-88U I see speeds of 150Mbps down and 6 Mbps up. Connected to the same line behind the SG-1000 I max out at around 10Mbps down and 4 Mbps up. I have tried following the various other performance threads without success. Trying to understand if I can match the 150Mbps down speed with the SG-1000. Any tips or help would be very much appreciated. Thanks!

  • Galactic Empire Netgate


    Can you please try an unmanaged switch between the modem and the appliance's WAN interface, then retest and let us know how it performs?

    Also, is pfSense receiving a public or private (within RFC1918) address?

    Thank you,


  • pfsense is receiving a public address. I have now tried one of these switches between pfsense and the modem -, no change in speeds, 10Mbps down and 5Mbps up

  • pppoe or just ethernet?

    have you tried other cables? how about error readings on the interface? half duplex / full duplex ?

    need more intel to go on

  • ethernet connection on WAN and LAN. Have experimented with different cables and different duplex/speed settings on the WAN interface. The speeds do seem to be peak a little faster the first speed test following a reboot, but by the second speed test the peaks are closer to the average.

    Havent been able to find any errors associated with the interfaces, though not totally certain I am looking in the right places, will continue to dig around.

    One thing that did seem curious is that while I perform a speed test from a client connected to the LAN, I can see the following process is always the top CPU consumer, however never peaks above 5% CPU

      10 root      155 ki31    0K    8K RUN    13:54  88.33% [idle]
      11 root      -92    -    0K  176K WAIT    0:08  1.86% [intr{aintc0,41: cpswss0}]

    Still researching, posting this in case it makes others think of something.

    Thanks for the help here, any other tips greatly appreciated.

  • Netgate Administrator

    Mmm, if it's on;y passing 10Mbps, 86% idle seems about right. That process looks normal.

    Does it show a link at 1Gbps on both NICs? What exactly is it connected to on the WAN? What does your ISP provide there?


  • I think the attachment shows that both interfaces are negotiating 1Gbps? Is there a better way to check for both NICs showing a link at 1Gbps?

    I have tried 3 different connections on the WAN, all showing the same throughput. directly into a Netgear CM600 - Then behind that CM600 both a TP Link TL-SG108 -, and an ASUS RT-88U - connecting into the SG-1000.

    My ISP is comcast and the package is advertised as 150Mb/s download speed and 5Mb/s upload speed. with the CM600 as the modem and the ASUS router I have seen speeds slightly greater than these advertised speeds, even over wireless.

  • Netgate Administrator

    Have you ever seen a faster speed than that? Is this a new deployment? In a previous location perhaps? It looks like that device is ~6m old.


  • Quick glance suggests Interface(s) somehow negotiated down to 10BT. Interfaces statistics under Dashboard should tell you exactly what's what, but I suspect undisclosed configurations on your part doing it. Did it EVER worked properly when you newly installed pfsense BEFORE any configuration changes?

  • I regularly see faster speeds through my Asus router on the same cables. I had this device on a different connection prior to its current location and saw speeds better than they are now. When I moved the device I set it back to factory defaults and upgraded to the 2.4 release. I went ahead and flashed back to the factory image, but no change in speeds. The interface statistics in the dashboard show both interfaces at 1000T.

    At this point I am thinking there must be some optimization within pfsense configuration for this specific device…any ideas?

  • i would disable ip6 on the sg 1k and see if your speeds change

  • I have gone into Interfaces and set the IPv6 Configuration Type to none for both interfaces. I have also disabled the DHCPv6 Server & RA service. No change in speeds with any of these configuration changes. Are there other settings relevant to disabling IPv6?

  • Netgate Administrator

    Just to confirm these are the speeds you're seeing direct right? Not via VPN?


  • Have gone through those steps to disable IPv6, no change in speeds.

    And correct, this is just a direct connection to my ISP, no VPN connections.