Unable to reach LAN IP after connecting to openvpn

  • I did config export files only this is what I got
    dev tun
    cipher AES-128-CBC
    ncp-ciphers AES-256-GCM:AES-128-GCM
    auth SHA1
    resolv-retry infinite
    remote 1194 udp
    verify-x509-name "mikeshouseserver" name
    pkcs12 pfSense-UDP4-1194-mikeshouseclient.p12
    tls-auth pfSense-UDP4-1194-mikeshouseclient-tls.key 1
    remote-cert-tls server

  • 2_1529079277609_pfsense3.jpg 1_1529079277609_pfsense2.jpg 0_1529079277608_pfsense1.jpg

  • 3_1529079316715_pfsense7.jpg 2_1529079316715_pfsense6.jpg 1_1529079316715_pfsense5.jpg 0_1529079316715_pfsense4.jpg

  • sorry pics seem to have posted out of order... but that's the settings of the server settings.. is there any other screen shots you need?

  • LAYER 8 Global Moderator

    @comet424 said in Unable to reach LAN IP after connecting to openvpn:

    but I loose internet and I cant ping…

    Can't ping what?? Is what your trying to ping set to allow you to ping from 192.168.100/24 - for example windows out of the box firewall will not answer ping unless your on the same network..

    You have to adjust the host firewall. For you to get internet access via this vpn connection, did you set your outbound nat for your tunnel network.. Should of done that for you, but if you had changed to say manual mode on your outbound nat than it wouldn't..

    When you connect to your vpn, can you ping your lan IP of pfsense?

  • @johnpoz Hi, I have already removed the custom option.
    My client IP is

  • LAYER 8 Global Moderator

    so do a traceroute.. What do you get from that?

    example here is traceroute to IP on my home lan network

    C:\Windows\System32>tracert -d

    Tracing route to over a maximum of 30 hops

    1 101 ms 108 ms 103 ms
    2 106 ms 101 ms 109 ms

    Trace complete.


    Its long because my proxy is all the way in TX, while I am at work in Chicago, so from chicago to hou, back to chicago, etc. So yeah some added latency.

    Ping and traceroute to the pfsense lan IP.. For example my pfsense IP on my lan is You trying to talk to devices on your lan might have host firewalls blocking your remote tunnel IP.

  • @johnpoz Hi, here is the story, I am able to reach the pfsense lan ip which is but to ping any f the ip which are belongs to 192.168.1.x series.

  • LAYER 8 Global Moderator

    Well then your going down the tunnel and as already stated points to host firewall, or the host your trying to ping using a different gateway other than pfsense.

    You not being able to get to say public iP down the tunnel would point to outbound nat not configured for your tunnel network on pfsense.

  • @johnpoz Hi, we are using only one GW and that is PfSense local ip and also able to ping or when I am in VPN.
    I am really clueless now :(

  • @johnpoz Hi, I got an log below, please help me to understand the same

    Fri Jun 15 22:54:01 2018 Block_DNS: Using existing sublayer
    Fri Jun 15 22:54:01 2018 Block_DNS: Added permit filters for exe_path
    Fri Jun 15 22:54:01 2018 Block_DNS: Added block filters for all interfaces
    Fri Jun 15 22:54:02 2018 Block_DNS: Added permit filters for TAP interface
    Fri Jun 15 22:54:07 2018 Warning: address is not a network address in relation to netmask
    Fri Jun 15 22:54:07 2018 ROUTE: route addition failed using CreateIpForwardEntry: The parameter is incorrect. [status=87 if_index=9]
    Fri Jun 15 22:54:07 2018 env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
    Fri Jun 15 22:54:07 2018 Initialization Sequence Completed

  • 2_1529086268703_nat3.jpg 1_1529086268703_nat2.jpg 0_1529086268703_nat1.jpg
    here is my outbound nat I set

    as for the pinging what I ment was on my cell I have a Ping program when I'm not on my vpn I can ping say which is my Freenas IP as soon as I connect to VPN I get the for my cell and I loose all internet.. I can no longer ping I cant ping the router or which be the router I in virtual lan setting and this happens when I connect open vpn using my home internet or at the coffee shop

    I'm sure its something simple like a check box I missed that's causing all this right? for the traceroute id have to be at the coffee shop with the openvpn to get the results you want correct?

  • the only ip address I can ping while on vpn is which is the cells ip address for the vpn..

    so I confused I thought was so simple like the video showed boom boom boom done now your perfectly connected... I had to missed a step some how probably some check box I missed

  • 1_1529087509032_rules2.jpg 0_1529087509032_rules1.jpg
    here is the Rules pics for the firewall for the openvpn

  • LAYER 8 Global Moderator

    @ayanbanerjee said in Unable to reach LAN IP after connecting to openvpn:

    Fri Jun 15 22:54:07 2018 Warning: address is not a network address in relation to netmask

    That is not a network that is a host!!! network would be

  • LAYER 8 Global Moderator

    you have 2 different people posting different issues. Its becoming a bit hard to follow..

    One guy says he has no problem getting to the internet through the vpn, the other says he can't etc. Just because your both having issues getting to your lan behind pfsense does not mean they are related to why.

    I wold suggest the 2nd guy start your own thread.

  • @comet424 Based on your screenshots, your outbound NAT only allows the specific IPs of and outbound to internet. Any other clients will not be NAT'd so they will not be route-able on the internet. You need to add outbound NAT for your VPN subnet. If you are receiving an IP of on your phone than I am guessing your VPN subnet is You should create a NAT rule for that network outbound. You will not need to select static port on that entry. As a side note, if you want the VPN to just give you access to things on your local network and don't need or want VPN access, you don't need the NAT entry but you need to make sure the box that says "Force all client generated traffic through the VPN" is unchecked in your VPN server settings.

    Hope that helps.

  • @bloodlogic ah I not sure and I posted a new article as I didn't wanna tick off johnpoz and confuse everyone more the is for the router nat.. the 51. is to try to get xbox one to work properly throught pfsense which didn't work... and I did the check all clinent generated track because I was told to try that for conflicts when I uncheck it it didn't help I was told like I thought if I use 192.168.0.x as my local network and I connect to a coffee shop that uses 192.168.0.x as there network if there would be a conflict.. I tried both ways check and uncheck no difference once I connect to vpn I loose all internet connection and no longer can ping expect the virtual IP for the cell

  • @johnpoz Ok but could you please check the line stating regarding route addition failed

  • LAYER 8 Global Moderator

    Dude you can not had a host address as a route.

  • @johnpoz thanks.. I was done some mistake on configurations.. but the ping issue still not solved.

  • @johnpoz Hi some more inputs from my side ,
    after vpn connection people from LAN able to ping my vpn ip, so its look like its working in one way. by any chance is there anything I need to do in firewall side ?

    Please help.

  • LAYER 8 Global Moderator

    THE HOST FIREWALL!!! ie the client on the lan side your trying to ping, its software firewall... Went over this way back in the thread..

    Windows out of the box is not going to let some IP (tunnel network your remote guy got from vpn) ping it..

  • @johnpoz I have disabled all the Windows firewall but no luck

  • LAYER 8 Global Moderator

    If you can ping your lan IP of pfsense, then your going down the tunnel.. Then that means you can get to the lan network... So sniff on the lan interface while you ping some lan client from your vpn... Do you see it send ping go towards the client. Do you see a response..

    Here is example from my phone pinging my box..


  • LAYER 8 Global Moderator

    did you mess with openvpn firewall rules.. The wizard will create a any any rule.. Did you delete this - not use the wizard? Modify it?0_1529141847646_vpnrules.png

  • @johnpoz the rule is there, i have used the wizard.

    look like problem is different, all the clients are getting same ip after connecting vpn :(

  • LAYER 8 Global Moderator

    Are you connecting multiple clients at the time? Multiple clients connected at the same time would not get the same IP. But yes client A connects, then disconnections and client B connects then sure it could get the same IP that A had before.

    What does that have to do with pinging inbound to something on the lan?

  • @johnpoz Yes I am connecting multiple client in same time and getting single ip for all the client, I think if we solve this issue we will be able to solve the ping issue as well.

  • LAYER 8 Global Moderator

    Are clients as using the same creds/certs access?

    Did you setup some client override following some previous guide that you did not remove?

  • @johnpoz Yes right you are i am using the same access and cert for 2 number of vpn connection.

  • @johnpoz Thanks for the pointing out the user access thing.. now ip is different for the different users.. please please help me on the ping issue please :)

  • LAYER 8 Global Moderator

    So your client can ping the pfsense lan IP - right?

    If so then the tunnel is there and your client is going down the tunnel. Then again this screams firewall on the host your trying to ping on the lan, or the device not having a gateway or pointing to different gateway that pfsense, or having a route that says your tunnel network uses a different gateway.

    Please sniff on your lan interface while you ping one of your lan IPs.. Like I showed in my example.

  • @johnpoz thanks TON to you for your all support, I am able to solve this issue by adding outbound NAT.

  • LAYER 8 Global Moderator

    So you had messed with your outbound nat like I brought up way earlier in the thread.. If your outbound nat is automatic when you run through the openvpn wizard it will add your tunnel network to the nat..

    Did you switch to automatic, or did you create some nat - mind posting your outbound nat screen..

Log in to reply