Lentidão ao baixar arquivo do webservice



  • Bom dia Srs,
    Será que alguém poderia me ajudar com esse problema por favor.

    quando clico para baixar algo do meu webservice simplesmente fica de 1 a 2 minutos rodando e depois baixa o aquivo.
    Já rodei e não descubro o que é, isso só ocorre quando boto o pf como firewall principal.
    Fiz um teste direto com um roteador e funcionou normal...

    alguém tem uma ideia por onde eu vou para descobri essa lentidão?
    obs.: segue um print em anexo.0_1535368069859_datapublic.png
    Se alguém puder me dar uma luz de onde começar... ficarei muito grato.



  • Qual as configurações do seu FW quando tu colocar ele como "Principal".



  • Boa noite, me desculpe pela demora.

    Configuração padrão só fiz o redirecionamento da porta, o resto tudo padrão.

    Configurei o ip na wan e fiz o redirecionamento para teste. .

    fica lento para fazer download do pdf... já tentei de tudo e não descobri... se alguém puder me ajudar por favor.

    abraços



  • Srs. Tudo na paz?
    ,
    De verdade eu venho tentando á dias pesquisando e tentando descobri o porque desse meu problema e sem avanço algum, venho pedir ajuda, se alguém puder me dar uma direção ficarei muito grato.

    Tenho um web service com windows 2012 e o IIS que hospeda um serviço de notas.

    Montei o firewall com o PFSense no proxmox e fiz o redirecionamento da porta em questão para o windows server 2012.

    Basicamente minha infro está assim:

    Internet <--> firewall <--> windows server 2012

    O problema é quando clico aqui:
    Srs. Tudo na paz?
    ,
    De verdade eu venho tentando á dias pesquisando e tentando descobri o porque desse meu problema e sem avanço algum, venho pedir ajuda, se alguém puder me dar uma direção ficarei muito grato.

    Tenho um web service com windows 2012 e o IIS que hospeda um serviço de notas.

    Montei o firewall com o PFSense no proxmox e fiz o redirecionamento da porta em questão para o windows server 2012.

    Basicamente minha infro está assim:

    Internet <--> firewall <--> windows server 2012

    O problema é quando clico aqui:
    0_1538951999052_sistema.png

    Ele simplesmente demora de 30 segundos a 1 minuto

    Para excluir a possibilidade baixei a versão nova do pfsense e refiz tudo do zero.

    Versão:

    0_1538952024924_versao_tela.png

    Regras do firewall
    0_1538952052191_firewall_lan.png

    Nat:

    0_1538952070585_nat.png

    Deu o mesmo defeito.

    Para tira a dúvida se era no pfsense eu baixei o smoothwall express e o ipfire, configurei e testei. Para minha surpresa tudo funciona normal, também fiz o teste usando o roteador da tplink e tudo funciona normal, ao clicar baixa o pdf quase que de imediato.

    Parti para outras soluções no Pfsense, desativando a verificação de checksum:

    0_1538952094213_checksum.png

    e desativando no proxmox também com o comando:
    ethtool --offload “placa” gso off tso off sg off gro off

    Não teve efeito algum.

    Também desativei no windows na placa de rede.

    No proxmox estou usando a placa:

    0_1538952119503_proxmox_rede.png

    Andei lendo que é totalmente compatível.

    Fiquei sem opções dentro dos meus conhecimentos e venho por favor pedir ajuda aos coletas se alguém tem alguma sugestão?

    Muito grato a todos que puderem de certa forma dentro do seu tempo me ajudar



  • Tentou colocar o pfsense em uma maquina fisica somente para testes? As vezes pode ser algo no proxmox que está causando essa lentidão.



  • @suporteita grato por ter respondido... pensei nisso também... vou fazer isso e retorno.



  • Bom dia Srs, primeiro me desculpem pela demora! ocorreu muitas coisas na minha vida... mais vida que segue! Deus sempre.

    por último instalei o pfsense em uma máquina separada e ocorreu a mesma lentidão ao baixar o arquivo.

    Se for pelo Tp-link baixa tudo normal mais pelo pfsense demora acredito que de 15 a 30 segundos.

    Realmente estou sem opções nesse caso. alguém poderia por gentileza me dar idéias de como eu possa pelo menos tentar descobrir o erro?

    grato a todos que me ajudarem.