Can I do fresh 2.4.4 install and restore a 2.4.1 configuration backup?

  • I've got a pretty straight forward pfSense installation. Only run 2 packages, bandwidthhd and iperf. I do have a ipsec vpn between two pfSense firewalls, but other than that, pretty straight forward.

    In order to preserve a way back I was just going to throw a fresh boot drive in the machine, install 2.4.4 and restore my backup configuration file. This way if there's a problem, I can just throw the original drive back in and I've returned to 2.4.1

    Is this a valid way to upgrade? Will 2.4.4 take the older configuration file? I have certificates (for the vpn) and I know there was something different about certs in the new version.

    I'm really excited to see if the new crypto feature will speed up my vpn at all but don't want to give myself lots of problems just for that.



  • LAYER 8 Netgate

    Yes. That should be fine.

  • @derelict said in Can I do fresh 2.4.4 install and restore a 2.4.1 configuration backup?:

    Yes. That should be fine.

    Well, that didn't work.

    I made a fresh backup file
    Installed 2.4.4 on a fresh HD
    Set interface IP to match existing
    Logged in to pfSense from workstation
    Restored config, rebooted

    From workstation I was able to get to the pfSense webpage but trying to login resulted in the page just hanging.

    Tried a few reboots, tried another workstation that hasn't been to pfSense (no cache), tried MS Edge (no cache) all gave the same result, no ability to log into pfSense.

    Swapped back original HD and all is fine.

    Ideas on what went wrong?


  • LAYER 8 Netgate

    Based no the information provided. No.

    What hardware?

    Did you look at the console at all?

  • I think I found the problem, but not entirely sure why.

    I have a flaky WAN network connector and any disruption causes it to not connect. i made sure it was connecting on 2.4.4 and tried again, this time I was able to get into the website just fine. VPN connection came back up with no problem. Going to test a bunch of other stuff.


  • LAYER 8 Netgate

    So Layer 1.

  • Seems to be working fine now. Not sure why a disconnected WAN interface would prevent me from accessing the webgui but in any event everything seems to be working just fine now. This week I'll upgrade the other end of my VPN and turn on Asynchronous Cryptography.


Log in to reply