ANOTHER multiple ps4 issue



  • I have a very unique issue, hopefully someone can chime in. As we all know you need a static port set for consoles to get an open nat type. However, when I do this for 2 or more ps4's they will not play black ops 4 at the same time. I have to disable one static port (giving me a strict nat) for the other console to connect to call of duty servers simultaneously.

    When I use a cheap home router, they work just fine together. I have been at this for days and any light would be much appreciated. Maybe even a pfsense alternative that does better with gaming as a last resort? I noticed black ops 4 will only go for port 3074 so maybe this has something to do with it? Older cod games would go after 3075 if the first port was full. But as I said, it works fine on the consumer router. One just ends up with a moderate nat which I am okay with.



  • Setting all Ports as static is BORKED!!! That is for sure..COD can not function with multiple devices behind it with all ports being static.. Since what happens when client A wants to use source port X and client B also tries to use source port X..

    That is not a valid solution in the long run with multiple clients using the same public IP.. Sooner or latter your going to run into conflicts NAPT not being able to do its thing if you tell it that all source ports need to be static..

    The correct solution to such a problem with ps4 needing some source ports be static is to set those specific outbound ports as static.. Not all ports ;)



  • Thank you for the reply. I figured it had something to do with both of them calling for the same ports. How do I go about setting it up to function? All ps4 nat videos just show setting up a static port for 1 console. Is there a tutorial for what I need to do that you know of? Such as knowing exactly what ports to designate to what ps4 and how?



  • @gtapro151
    Try this

    Youtube Video

    I setup for two Xbox One X at home, but we haven't played at same time however they both show nat type as Open.

    Only thing I did different for this tutorial was set the outbound NAT to Hybrid so other UPnP stuff works.



  • Is the video linked by brians showing the right way to open NAT?


Log in to reply