OpenVPN Client connects but can't access anything except ICMP



  • Hi,
    I able to establish Openvpn client connection, but can't access anything on that network. I am able to ping everything, but sudden packet drop will occurs when I try to connect through rdc or vnc. Finally cant access anything.I can't find any unusual openvpn log, so where do i check apart from openvpn log.
    Regards
    Sreyas



  • Need more details. Post a network map. Post your server1.conf (/var/etc/openvpn)


  • LAYER 8 Netgate

    Either asymmetric routing, not passing TCP/UDP, or, maybe but probably not MSS.

    Check the firewall logs for blocked packets related to the connection you are making.

    Packet capture the OpenVPN instance and make an attempt. See what's happening with the TCP connection. If you see it there, pcap on the LAN and see what's happening there.



  • @marvosa please find the attached conf file for your ref:0_1546173003617_Server1.conf.txt



  • Thx for posting the config. It would also be helpful to include a network map so we have an idea of how things are connected.

    Your config looks ok. I see a tunnel network of 10.70.0.0/16 and it looks like your LAN is 10.30.0.0/16. Both of those subnets are entirely too wide, but it's probably not your issue.

    If ICMP is working then routing is working and you need to look at your firewall rules. What do your firewall rules look like?



  • @marvosa I WILL SEND YOU THE NETWORK MAP SOON, ONE QUICK UPDATE

    1. THIS IS HAPPENING ONLY FOR SOME SPECIFIC ISP
    2. MY FIREWALL RULE FOR VPN IS ALLOW ALL
    3. I HAD CREATED SOME EASY RULE WHICH I HAD SEEN IN FIREWALL LOG FOR THOSE CONNECTIONS GOT BLOCKED.