Squid de PfSense no deja ingresar a la pagina: http://app.incop.go.cr/servicios/Default.aspx



  • Buenas tardes

    Espero y se encuentren muy bien, tengo el siguiente inconveniente, no puedo ingresar a la pagina http://app.incop.go.cr/servicios/Default.aspx utilizando proxy no trasparente en el pfsense, se queda intentando ingresar pero no lo hace y al final sale el error:

    Se encontró el siguiente error al intentar recuperar la dirección URL: http://app.incop.go.cr/servicios/Default.aspx
    
    Error de Lectura
    
     El sistema ha devuelto: (60) Operation timed out
    
     Se ha producido un error al leer datos de la red. Por favor, inténtelo de nuevo. 
    

    He intentado:
    -Agregar el dominio incop.go.cr en la lista blanca del squid.
    -Crear una regla de firewall en la interfaz LAN para dejar pasar el trafico a la IP publica que hace referencía http://app.incop.go.cr/servicios/Default.aspx.
    -Creé un archivo .acl dentro de /var/squid/acl y lo metí en las opciones avanzadas del squid del pfsense para dejar pasar el trafico que vaya a ese dominio de manera directa.
    -Revisé si a la pagina se accede mediante un puerto que no sea el 80, pero parece ser que sí usa dicho puerto por lo que no hace falta meterlo en la lista de: ACL SafePorts y ACL SSLPorts.

    Pero ninguna de esas opciones me han funcionado, si le doy salida libre a la PC mediante una regla del firewall (sin proxy) se puede acceder a la pagina sin ningún problema, el inconveniente se presenta solo cuando autentico mediante el proxy del pfsense.

    Ya he hecho las pruebas en diferentes versiones de pfsense pero en todas me sucede lo mismo, por lo que les pido la acostumbrada ayuda con la intención de que tal vez alguno tenga una idea de cómo solucionar dicho inconveniente.

    El pfsense con el que mayor mente hago pruebas (Netgate SG-2440) tiene la siguiente versión: 2.4.3-RELEASE (amd64) built on Wed Mar 28 16:32:48 CDT 2018 FreeBSD 11.1-RELEASE-p7, utilizo el squid de manera "no transparente" y la versión de squid instalado es: 0.4.43.

    Espero y alguien tenga una luz para solucionar dicho tema, muchas gracias por la ayuda que me puedan brindar.



  • @bcalvo Buenos días Señor @bellera espero se encuentre muy bien, quería consultar sí tal vez su persona tuviera alguna luz que me pueda ayudar con dicho inconveniente.



  • Cuando me ha pasado casos así puntuales, ha sido el 90% el hosts remoto.

    Un caso parecido nos paso con un Banco. Tanto fue que tuvimos que llamar al Banco, y sus técnicos nos dijeron fue: Es que tenemos un modulo de seguridad en nuestro servidor web, que si detecta que la conexión viene de un proxy, no lo deja pasar.....



  • Muchas gracias por la respuesta @j-sejo1 , efectivamente es algo inusual, he tenido algunos años trabajando con pfsense y hasta ahora se me presenta un tema así, sin embargo, llamé a la empresa de la pagina a consultar sobre el tema y me indicaron que no han realizado ningún cambio, la respuesta que me dio la persona encargada de TI fue que sí funciona con un internet libre o en celular, debería de funcionar en cualquier lado.

    He intentado de muchas maneras y solo al pasar por el proxy se me presenta dicho inconveniente, por lo que tal vez algún otro miembro o su persona me pueda ayudar con el tema, de igual manera muchas gracias por la ayuda.



  • Buenas tardes, aún tengo el inconveniente que les he comentado, tengo la idea de que el error se puede deber a que dicha pagina dura mucho cargando(problema meramente del hosting o proveedor de dicha pagina), por lo que quisiera consultar si existe la manera de aumentar el tiempo de intento de conexión en el squid del pfsense a las paginas.

    Básicamente lo que busco es la manera en que no salga el time out si no dar más tiempo para que se pueda establecer la conexión.

    Si alguno tiene una idea por favor me ayudaría bastante.

    Saludos.