Pfflowd - Not starting SOLVED

  • I ran into a problem running PFsense 1.2.2 (release) with the current pfflowd package. After a clean install of the pfflowd package the service would not start. So with a ton of research I traced down how this package starts within PFsense and what was the cause of my problem so I thought I would post if for fellow PFsense users.

    1. When PFsense is started it runs the following script (/etc/rc.conf) you will see a line tward the botom of this script that basically executes any files contained within the /usr/local/etc/rc.d area (when running the HD installed version of PFsense, the CD version is a different directory due to the portable config) the line within the script looks something like this

    Start packages

    2. That starts the following script in the directory noted above (here is where you will see the reference for the CD ROM version and the other or file version)


    Set our operating platform

    PLATFORM=cat /etc/platform

    if [ ! "$PLATFORM" = "cdrom" ]; then

    /etc/rc.packages 2>/dev/null

    echo "Executing rc.d items… "
        for FILE in /usr/local/etc/rc.d/*.sh; do
    echo -n " Starting ${FILE}..."
    sh $FILE start >>/tmp/bootup_messages 2>&1 &
    echo "done."

    3. Note this line in the above script (for FILE in /usr/local/etc/rc.d/*.sh; do) this line basically executes any file within the /usr/local/etc/rc.d directory. Each package you install in PFsense will have a start up script that is manipulated and created by the GUI interface of PFsense. You will see one script in this directory for each package that involves a service. Any disabled packages etc will not have the .sh extension. Without that extension the script will not run. This is handy for dev's that may have multiple services within a package to allow one service to be ran without the other. In my case with pfflowd the pfflowd start up script was in this directory however it did not have the .sh extension. So by all accounts it was disabled. I could start and stop the service via the GUI without error however the service would never actually start since there was no start up script to perform the operation. Once I renamed the file with the .sh extension it ran perfectly and the GUI was able to modify the start up script to include the necessary settings to launch pfflowd sucessfully.

    I thought not only the fix but how I got there would be handy for the community. THANK YOU ALL for contributing to such a great product.

  • Thanks for sharing the solution! I'm sure it will be helpful for some people.

Log in to reply