allow haproxy to listen to wan port 80 (and stop redirecting to pfsense admin page)



  • Hello,

    I did some searching: I am trying to run haproxy on my firewall listening to the wan ip address. But my browser is receiving a 300 redirect to https://...:8443/ which is my admin page. I am certain I am not using my lan ip address in my browser, and my browser is via my cell phone tethering.

    I have the "Disable webConfigurator redirect rule" checked, but this changes nothing. I have cleared my browser's cache.

    This is pfsense 2.4.4-p2. I have my webgui bound to https port 8443.

    What am I missing?
    Thank you for your time...

    --jason


  • Rebel Alliance Developer Netgate

    If you disabled the option to redirect, then it has to be a redirect cached by your browser.

    Try a different browser, or private/incognito mode.



  • It works now. It's funny how I used incognito mode on chrome, and a cache zapper in place and still had the problem: browsers are tenacious at caching info...

    Thank you for your time Jim!



  • @jason0
    The HSTS cache can be a bit extra tricky to get rid of also.. Instructions for most browsers can be found though.


Log in to reply