Installation - Vga fails.

  • Hi

    Im trying to install newest pfsense on a new machine, but I get this weird console after booting(pic 2 & 3) . boot loader looks fine (pic 1).
    Can i add a boot option to the kernel so I can change the resolution? Ive tried to do a set.kern=sc boot that stalled the booting (pic 4)

    Any ideas would be great.

    Pic 1:
    Pic 2:
    Pic 3:
    Pic 4:

  • Rebel Alliance Developer Netgate

    At the first boot menu, use option 3 to go to a loader prompt.

    From there, type:

    set kern.vty=sc

    If that helps, then after you install, on the first boot, do the loader prompt again, then once it's up, edit /boot/loader.conf.local and add a line for kern.vty=sc.

    You might also have some luck with BIOS options for booting EFI vs Legacy or maybe some graphics option

  • @jimp thats actually what i tried in picture no. 4 but it failed to go further than the EFI frambuffer information. Can I pass other vga modes on the loader prompt?

    .. I havent been able to install due to I cannot read the screens :-) (pic 2 and 3)

  • Rebel Alliance Developer Netgate

    Ah, I didn't see that in the last pic, just noticed the panic.

    You might try this instead:

    set hw.vga.textmode=0
    set kern.vt.fb.default_mode="1280x800"

    Try the first one alone, and if that fails, try them together.

  • @jimp thanks, I tried different resolutions - but the text is still gibberish - I can see it scrolls so the installer is booting but its unreadable ...

  • Rebel Alliance Developer Netgate

    Maybe try a 2.5 installer from

    Otherwise it's probably some kind of incompatibility with that hardware. Might try a BIOS update, change some BIOS options, maybe drop in a different video card if you can.

  • @jimp the 2.5 installer is doing the same thing

    its an Intel atom E3940 with integrated chipset. so I guess I have to try some serial installation instead. .. hopefully I can add a usb serial connection and try this ..

  • Rebel Alliance Developer Netgate

    USB serial wouldn't work for a console, has to be an onboard port.

    Also be sure to try all the different variations (regular, kern.vty=sc, etc) on the 2.5 ISO if you haven't already.

    And there is always the BIOS option route. Especially EFI options.

  • @jimp the iso boots and the graphics is okay ... guess the memstick and iso arent the same .. thanks for your help!

  • I have the exact same issue.. using a N4200 processor (same Apollo Lake as E3940)

    Tried 2.4.4 and 2.5.0-latest with same result as pic 2 & 3
    set kern.vty=sc
    Also freeze like picture 4

    "set hw.vga.textmode=0"
    Same as pic 2 & 3

    "set hw.vga.textmode=0"
    "set kern.vt.fb.default_mode="1280x800""
    Same as pic 2 & 3

    Booting EFI, as platform does not support MBR boot.

    Any other advise for installation? or is this hardware generally a problem?
    Current unable to complete an installation :(

  • Rebel Alliance Developer Netgate

    @karlshoj said in Installation - Vga fails.:

    Any other advise for installation? or is this hardware generally a problem?

    Either a BIOS or hardware incompatibility with FreeBSD. There may be BIOS options you can try, or a BIOS update.

  • No BIOS options that are related to this (very limited options in BIOS)

    Freebsd 12.0 show the same problem.
    Latest build of Freebsd 13.0 are working correctly, this means that this problem with Apollo Lake is solved in FreeBSD 13.0

    • Pfsense 2.5 are based on freebsd 12.0, so a long time for a solution.

    Anyone have an idea why it work in Freebsd 13.0 and if any work around is possible?

  • Anyone with an idea why FreeBSD 13 works and FreeBSD 11 + 12 fails?
    Or a work around for current PfSense version on Apollo Lake?

  • Rebel Alliance Developer Netgate

    That's a question for a FreeBSD forum. They must have made some change in FreeBSD that helps it work on that hardware. Probably newer drivers in one area or another. You'd have to ask them to know for certain.

Log in to reply