Connecting via PPPoE modem on WAN to TalkTalk (UK ISP)

  • Hi,
    New here, so if this is in the wrong section, please let me know.

    pfSense : 2.4.4
    Installed on AMD64 CPU with 2G Ram, 3 network cards (WAN/LAN/OPT)

    I am trying to get pfSense to connect to my ISP via a PPPoE modem to replace my ageing Draytek router.

    I can connect via PPPoE with my draytek without any issues. but when i try and configure pfSense with PPPoE on the WAN port, I can't get connected.
    On the draytec, I just need the Username and Password for the PPPoE connection, and am using the defaults in pfSense for setting WAN as PPPoE.
    This is a fresh install of pfSense 2.4.4 latest, no changes to install made other than setting internal LAN cards IP addy and then adding the username/password for the PPPoE connection under the WAN interface via the web portal.

    Anyone able to give me any pointers on getting this to work?
    I am using TalkTalk ISP in the UK, and a BT Openreach (ECI Telecom Ltd) PPPoE external modem.
    I can confirm that everything works fine when using the Draytek router in place of the psSense server.
    WAN Interface settings :
    Enable Interface
    ipv4 Configuration Type : PPPoE
    IPv6 Configuration Type : None
    MAC Address : BLANK
    Username :
    Password : <ISP-Password>
    Service Name :
    Dial on demand : Enabled
    Idle timeout : BLANK
    Periodic reset : disabled
    No Advanced/MLPPP settings changed.
    Block private networks and loopback addresses : Ticked
    Block bogon networks : Ticked

    Only thing i noticed was you can't save the settings without inputting a timeout, but after setting this to '0' and saving the setting shows blank when viewing the interface again.
    Have tried with both Dial on demand and without.

    PPPoE: Connecting to ''
    PPPoE connection timeout after 9 seconds
    Link: DOWN event
    LCP: Down event
    Link: reconnection attempt 44 in 4 seconds

    Please let me know what logs i can post back to help any diagnosis.


  • Galactic Empire

    Looks about right, I'm with Zen Internet and also have the same modem, try leaving the Service name blank.

    Talktalk don't use vlans on the PPPoE interface do they ?

  • Netgate Administrator

    There is a VLAN required but the Openreach modem adds it by default, you should not need it in pfSense.

    Check the PPP setup directly in Interfaces > Assignments > PPPs.

    If it looks good there check the actual WAN PPP sections in the config file.

    Do you see anything else in the ppp log? It looks like it's missing a connection name there somehow.


  • Thanks guys.
    Just wanted to update this for anyone in the future. I gave up using the old PC for the firewall and ended up getting a nice little SG1100.
    Plugged it in, configured LAN via console, logged into the web frontend and followed the setup wizard.
    Simply entered the PPPoE username and password and it all worked.
    Not sure why it didn't like connecting on the PC, I suspect that some previous attempt had changed something that was causing the issue.

    Thanks again

  • @marl_scot
    Out of curiosity can you explain the physical setup? I've got an SG1100 as well and TalkTalk
    Was the connection something on the lines of:
    Talktalk wall socket - [RJ11 into] Draytek 130 Modem - [RJ45 into] Wan port of SG1100?
    Did you have to do any configs on the modem if you used it?
    And where did you get the username and login for the SG1100?

  • Netgate Administrator

    That should be all you need for a standard FTTC connection in the UK.

    Just configure the WAN as PPPoE and add your login.


  • @AdmiralBTech , The system is setup as you described it.
    Only thing I had to do to get it up and running was to go through the inital howto on setting up the SG1100 (as I was replacing an existing system so had to match previous settings, if you dont need to worry about this, then its a bit easier).
    Once I could connect my laptop to the LAN port on the SG1100, I logged in with the default username and password (I believe it is admin/pfsense for the user/pass).
    Then I went followed the setup wizard to configure a PPPoE for connecting to the internet and entered the TalkTalk broadband username and password (I think the talktalk username is normally something like but I would need to double check this to be certain).
    Once I completed the setup wizard I was up and running.
    The original problem I had was because I installed the Pfsense software on a PC (to save time and money) but messed something up while trying to test things. If I reinstalled the old PC and ran the setup wizard then most likely it would have worked without any issues.

  • @stephenw10
    Hi Stephen.
    Unfortunately according to TalkTalks "Set up a non TalkTalk router"

    Authentication DHCP/IPoE
    Vlan ID 101
    DNS Automatic
    Username and Password:

    @marl_scot I found my username but can't find what my password would be. Where did you find this or did you ask TalkTalk directly?

  • Netgate Administrator

    So...not PPPoE then. Is that specific to their FTTP implementation? Their FTTC stuff is standard PPPoE when I've seen it.

    You have a link to that?


  • Netgate Administrator


    Looks like it's DHCP, no username/password required. Just have to set the WAN to be VLAN 101 if the modem/ONT doesn't do that already.


  • Seem to remember getting the password from TalkTalk, pretty sure it was setup as PPPoE, would have to get onsite to confirm which isn't likely to happen any time soon! sorry.

  • Netgate Administrator

    For FTTP specifically? Or FTTC, which is like most other UK providers AFAIK?


  • Hey everyone.
    I've managed to get everything working.
    I am using TalkTalk Faster Fiber
    This is my setup now:

    TalkTalk ISP wall box
    -> RJ11
    Draytek Vigor 130 Modem

    Had to log onto it and manually configue it to be in Bridge mode)

    -> RJ45
    pfSense SG1100

    IPv4 and IPv6 configured as DHCP

    I hope in the future this will help people who had the same questions I did!