Recent Switch from Tomato to pfSense Seems to Break Apache Rewrite

  • I recently switched from an Asus router running Advanced Tomato over to pfSense. (As a side-note: the switch was motivated by trying to get full speed on a newly obtained gigabit conenction...which is working well!)

    I run an Apache webserver on a virtual machine, and have ReWrite rules to redirect an http connection to https. This redirection worked fine under Tomato. It no longer appears to work through pfSense.

    A direct connection to the server via https works fine through pfSense.

    I have tried modifying the Apache ReWrite rules and also tried changing to a straight redirect directive in Apache, but still no success. I can post configs from pfSense and/or Apache if needed, but was wondering if someone else has run into this, or immediately knows why the rewrite/redirect approach doesn't work.

    Note that I am not trying to connect via internal LAN. This is not a NAT reflection issue.

    Thanks for any help.

  • After some packet capture, I located a typo in my NAT / Port Forward table. All working as expected now.