New Failure For Me...pfSense Machine Errors, etc.

  • Well, this is a new one for me. Yesterday, just chilling drinking coffee in the morning watching youtube and the internet starts going through a disconnect, reconnect, disconnect, etc cycle. I log into the console and see this...

    pfsense error.jpg

    I reboot with no luck. I tried to reflash with the latest saved backup with no luck. I tried the one previous too with no luck. (this was more difficult than I thought since I've been saving backups to my NAS, and without a router presented a challenge). At this point, I was able to get to the pfSense welcome screen and decided to burn it down and go with option 4: reset to factory defaults. I was able to reset but got the same issue when configuring my VLANs.

    At this point, I'm pretty sure it's a hardware issue. The motherboard I'm using (have been using for the past couple years) is a Supermicro A1SRM-2758F and I've never had any issues with it. The NIC I'm using is a Supermicro branded 10GbE intel card. Hearing the horror stories about Intel 10gig cards, I switched to a Chelsio 10Gig card, but it ended up being stuck on "starting DNS resolver". I think I have a corrupted SSD. I can't get the machine to reboot.

    At the moment, I've decided to try and reflash the image and start over from scratch with a fresh install and different NIC. If that doesn't work, I'll probably look into a whole new motherboard/machine.

    Any ideas or insite?

  • Netgate Administrator

    Intel 10GbE cards are generally pretty good currently. Did you have more than one 10G port in use? Which port was irq260 servicing? Which interface was that?

    You can up the interrupt threshold but if it really is a storm there that probably wouldn't help.
    sysctl hw.ix.max_interrupt_rate


  • Agree with @stephenw10 - there are few issues with just certain models of Intel cards, but overall they are pretty solid it. Chelsio support is also quite good for FreeBSD - which card are you using? Also, have a look at this link:

    Next time you see the interrupt storm messages occurring, try running "vmstat -i" from the command line to track down the culprit device (interface).

    Hope this helps.