How to change Chelsio T580 40gbe mode in pfsense command line?

  • I've got a fresh pfsense installation and I would like to change the T580 qsfp adapter mode from 40gbe to 4x10gbe (because I'm using a breakout cable). Where can I do that in the pfsense command line? I found on linux you can call the "" script, but this command doesn't work in the pfsense shell. I also didn't find anything about it in the Chelsio-UnifiedWire-FreeBSD-UserGuide.pdf.

  • Netgate Administrator

    Hmm, not something I've ever seen done in FreeBSD/pfSense. I see nothing that looks like it would do it in either cxgbe or cxgbetool.
    Is that a persistent setting? Can you boot Linux to set it?


  • Netgate Administrator

    Actually it looks like that change is done by uploading a different config file to the card so it should be possible to set the mode in any OS.
    Also there is code for FreeBSD to do this:


  • @stephenw10 I was able to mount a usb drive with the Chelsio utility for T5 adapters. I executed the with the following command in /usr/local/bin:


    The config file seemed to work, it asked to choose the chelsio adapter and to select the adapter mode. After selecting the second mode, which is Spider(4x10G), I got the following output:

    /usr/local/bin/t5seeprom -b 1:0:0 write -f:/usr/src/sys/dev/cxgbe/firmware/adapter_configuration/t580_lp_cr_init_gen3_500Mhz_variable_2133_vpd.bin
    Error in running command: ('Shared object "" not found, required by t5seeprom"\n',)

    I checked in /usr/local/lib and the is not there. Should it be?

  • Netgate Administrator

    Not by default. You can add it from our repo, for example by installing flashrom:

    [2.4.4-RELEASE][admin@5100.stevew.lan]/root: pkg install flashrom
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 3 package(s) will be affected (of 0 checked):
    New packages to be INSTALLED:
    	flashrom: 1.0 [pfSense]
    	libpci: 3.5.6_1 [pfSense]
    	pciids: 20180428 [pfSense]
    Number of packages to be installed: 3
    The process will require 2 MiB more space.
    399 KiB to be downloaded.
    Proceed with this action? [y/N]: y
    [1/3] Fetching flashrom-1.0.txz: 100%  154 KiB 157.7kB/s    00:01    
    [2/3] Fetching libpci-3.5.6_1.txz: 100%   50 KiB  51.2kB/s    00:01    
    [3/3] Fetching pciids-20180428.txz: 100%  195 KiB 199.4kB/s    00:01    
    Checking integrity... done (0 conflicting)
    [1/3] Installing pciids-20180428...
    [1/3] Extracting pciids-20180428: 100%
    [2/3] Installing libpci-3.5.6_1...
    [2/3] Extracting libpci-3.5.6_1: 100%
    [3/3] Installing flashrom-1.0...
    [3/3] Extracting flashrom-1.0: 100%
    [2.4.4-RELEASE][admin@5100.stevew.lan]/root: rehash


  • @stephenw10 Will try that! Thank you!

  • @stephenw10 It seems to have worked! I'll have wait to till I receive the breakout cable to validate that it worked!

Log in to reply