• I've noticed that Bandwidthd in pfSense 2.4.5 seems to have the frame to view it squished down WAY too small, and if you open it outside the frame it also seems to not be showing the bandwidth on any of my VLANs (only the default/native VLAN - all VLANs/subnets run thru the physical LAN interface) thru the router.

    Did something change in 2.4.5 that broke how Bandwidthd works? I've tried a clean pfSense install and reloading my backup configuration, reinstalling the Bandwidthd package, and reviewing my settings in Bandwidthd to ensure I'm picking the "LAN" interface and selecting the appropriate subnets. I thought this used to work before...and I know the view portal was a reasonable size before.


  • Same here after updating from 2.4.4P3 to 2.4.5
    Removed the package and reinstalled it and I got a message saying that there is no maintainer anymore for it, so maybe that's why it's not working, since, probably it wasn't properly tested with this release.
    Hope the package will have a maintainer in the future.

    But, if anyone has a workaround for the current situation, please share.

  • That's really a shame. I missed that part, and I'm not aware of anything that provides that sort of per-host and total bandwidth metering. It's helped me quickly track down problems in the past to understand which hosts are sending more data than expected.

  • https://redmine.pfsense.org/issues/10439 has another report, although Jim Pingle says it works for him. I don't know the answer, does deleting the package delete its data on disk?

    https://docs.netgate.com/pfsense/en/latest/monitoring/monitoring-bandwidth-usage.html has a few other packages, which I haven't tried.

  • @teamits Probably not, since if you reinstall the package, you will get the same settings as before the reinstall.
    So settings are kept somehow.
    Would there be a way to ask Jim Pingle on this?

    Also: https://docs.netgate.com/pfsense/en/latest/monitoring/monitoring-bandwidth-usage.html talks about Netflow and VNStat which don't show-up in my available packages.

    alt text

    alt text

  • I will say Bandwidthd is working for my default/native VLAN on the LAN interface - but it only shows if I click to view outside the frame. Other subnets show nothing and I was fairly sure they used to show something (but hard to be 100% sure).

    The frame not being sized right is the current most frustrating thing (to me).

    For context in my screenshot:
    192.168.1.x is my "default" untagged VLAN on the LAN interface most of my trusted personal stuff
    192.168.2.x is my guest VLAN id=2 on the LAN interface (which my work laptop is busily routing data onn)
    Maybe this will better illustrate what I'm seeing...it used to be quite usable without opening it in a separate window.


  • @pbnet I don't see either by name, but found some stuff mentioning those in my packages...

    For vnstat, it sounds like the command line tool I've used on Linux. Gives a total "thru the one pipe" but I don't think it would break out to tell me, for example, my HTPC is sucking up 50GB today, my Verizon Network Extender microcell used up 20GB, my NAS used 100GB...the description sounds like it would just say "you shoveled 170GB today total" and that's it.


    I see 2 packages on mine that sound like they can send "something" to Netflow but it sounds like some 3rd party (maybe Cisco?) product that you'd have to run separately? That doesn't sound like it would be a replacement/equivalent.


    Neither sounds like what we've had.

    EDIT: I'd also point out, when I just tried installing the traffic-monitor package with vnstat it mentions that too is not maintained...

  • @mmiller7 I use Bandwidthd the same as you are:

    alt text

    I've also installed DarkStat, but doesn't really do what BandwidthD did....

  • Hi all, did you find a fix?

    I noticed that is you click "Framed View [click to remove frame]" you can see the report but the framed view truncates the display as the original posted showed.

    Not a huge deal but annoying.

    BTW, this is on Chrome, Linux if it might be a browser issue.

  • @hedrinbc Windows/Firefox as well. If I play with the HTML a bit, if I specify a height on the iframe container, <div class="panel panel-body">, of say 1000px, the iframe will expand, since the iframe has a height of 100%.

    Looking at a router on 2.4.4 the iframe tag is:
    <iframe id="bandwidthd" src="/bandwidthd/index.html" scrolling="no" style="overflow: hidden; width: 100%; height: 15882px; max-width: 100%;"></iframe>

    On 2.4.5 it is:
    <iframe id="bandwidthd" src="/bandwidthd/index.html" scrolling="no" style="overflow:hidden; width: 100%; height: 100%; max-width: 100%;"></iframe>

    So it would appear something was calculating the correct iframe height and is no longer doing so?

  • Per https://github.com/pfsense/FreeBSD-ports/commit/183cabc59ca0b65368d1a8f6ffe967f80a46a6d2#diff-24986f02c41aa576cbf334c961135ee3 this is at the bottom of the page:

    <?php include("foot.inc"); ?>
    $('#bandwidthd').load(function() {
    /* Find height of iframe contnet and then add 20px for padding */
    $(this).height( $(this).contents().find("body").height() + 20 );

    It renders as:
    <script type="text/javascript">CsrfMagic.end();</script></body>
    $('#bandwidthd').load(function() {
    /* Find height of iframe contnet and then add 20px for padding */
    $(this).height( $(this).contents().find("body").height() + 20 );

    ...with the script after the </html>. Firefox marks this as "stray start tag 'script'" under View Page Source. Wild guess, the include("foot.inc") is now generating the </html> before the script tag.

    @jimp are you the jim-p that edited the package? :) (edit: Just because I figured you might know if something changed and be able to edit it quickly. Also if my guess is correct it might affect other packages/pages.)

  • Dug into this a bit more today and created https://redmine.pfsense.org/issues/10911

    The script tag after </html> was rendered that way in 2.4.4. However Firefox is logging JavaScript error "e.indexOf is not a function" in the frame-resize script after the 2.4.5 upgrade.

  • Good news, it was a jQuery issue [.load() removed in favor of .on( "load", handler )]: https://redmine.pfsense.org/issues/10911#change-48604
    The package has been updated.