UPNP and CoD MW2 on PC



  • This is my first post on this forum so please forgive me if this has already been adressed...

    I have been using pfsense for a while now and things have been working fine, great in fact. The one thing that is NOT working as I had hoped is with one particular game, namely MW2 on my PC. I am having trouble getting Open NAT on it... I CAN actually get it to work, see below but it's no where near automagic... All other CoD games I play, from the old MW to WWII, work great and report Open NAT (those that do report it).

    I have confirmed that port forwarding is working as I have that set up for hosting a TeamSpeak server as well as a few other things I have on my network, no problems there. I am also using UPNP and and have gone through every guide I have found and have it set up to allow for just the gaming PC's set Static IP for them as well. It's working fine, and I can see the ports being requested by the PC when I start up e.g. MW3 which requests and get port 3074, and it reports Open NAT.

    I have actually identified the port that MW2 wants but is for some reason not seeing/accepting as open (28960). It doesn't matter if I port forward it to the gaming PC in question. I have also tried every other port that is listed for that game but this one I know is the problem port...
    What DOES work for some strange reason are the two "solutions" below. And I'm hoping some of the developers or someone with much more knowledge than myself can figure this out... and perhaps based on this come up with a way to make it "stick".

    Solution 1:
    This one I found in some guide on YouTube but it doesn't work the same way for me as the guy showing it. On my gaming PC I go to my Ethernet card's Properties and set up Internet Sharing using port 28960. I then activate Internet Sharing, and the directly deactivate it after which I "quickly" start MW2, which most of the times then report Open NAT. If I wait too long before starting MW2, I get strict NAT. If I instead leave Internet sharing on, MW2 gives me a box that sais it's "connecting to IW net"... but nothing more happens.

    Solution 2:
    Double NAT...
    I place DDWRT (or any home router basically) behind pfsense, as a gateway/firewall essentially creating a separate subnet and activating UPNP on that router. I can now see port 28960 being opened in DDWRT towards my PC, as well as by pfsense towards my DDWRT router, and MW2 is reporting Open NAT...
    I guess what's happening is that DDWRT and MW2 seem to agree on how to opent the port. And at the same time pfsense and DDWRT are also agreeing on that side so MW2 is getting through just fine.




Log in to reply