Virtualbox + PFsense step by step guide

  • Hullo members,

    please post kindly a step by step guide for installing PFsense in virtualbox running in winXp sp2 upto a working state.

    Thanks in advance

  • Just download the iso and load it as a cdrom in the virtualbox.
    Then install it normally as you would on real hardware.

  • Rebel Alliance Developer Netgate

    I have had to disable VT and/or ACPI to run pfSense in a stable manner inside of VirtualBox, but otherwise it has performed very well.

    Also, use the PCNet II network adapters. I had trouble with the PCNet III's and the Intels were not detected at all (which I found quite odd)

    Just attach a pfSense iso to a VM, boot, and install just like a normal PC.

    I'll try to write up something for the Wiki if I get a few minutes this week.

  • Rebel Alliance Developer Netgate

    Also, I'm not sure if it's just me, but I've been having trouble (on two different systems) with certain VMs locking up and taking 100% CPU, which can only be resolved with a reboot.

    Seems that VirtualBox may still have some kinks, but it has come a long way.

  • I can not get any NIC type other than PC-NET III to get past detection, but then it does not seem to want to actually work on the network.  Here is my setup:

    Host: Ubuntu 9.04
    VBox: 2.2.4-47978_Ubuntu_jaunty (from Sun's repo, not Ubuntu's)
    pfSense: installed from pfSense-1.2.3-RC1-LiveCD-Installer.iso
    Ram: 512
    HD1: 2GB
    <the ram="" and="" hd="" specs="" are="" on="" purpose="" because="" i="" am="" testing="" for="" a="" specific="" board="" we="" have="" order,="" this="" is="" the="" of="" that="">NIC1 -> Wan: Tried both NAT and Bridged, neither works
    NIC2 -> Internal Network
    <also attached="" to="" that="" internal="" network="" is="" a="" ubuntu="" unr="" install="">The wan does not pick up the DHCP from our corporate network.  The UNR VM does not get DHCP information from pfSense.  I also have another VM that is built from Ubuntu Server that is also being tested for deployment on that same equipment.  It runs DNS and DHCP also, and the UNR machine does receive DNS and DHCP, and properly routes via that server, so I do not suspect the UNR instance to be the issue.  I suspect it is something that BSD/pfSense has issue with when built inside VBox.

    I have tried all five options for NIC.  It was installed with the PC-NET III card, and installed, but does not seem to actually work.  I have seen other posts in a number of forums that this is a bug, and suggest the Intel cards as a solution.  But all three of the Intel cards, as well as the PC-NET II will not detect the "network up" event during configuration, and thus will not allow pfSense to boot.

    Just to answer the next question that I know I will get asked… I am looking at pfSense because its already configured to handle interface failover, which is very important to our project, While Ubuntu can do it, its a very specialized configuration.  I like the out of the box failover of pfSense.  But can not get it tested!!!

    Please help somebody.</also></the>

  • Rebel Alliance Developer Netgate

    PC Net II's work fine for me.

    Don't rely on the "Network Up" event for autoconfigure, just type in the proper interface names based on how you configured them in VirtualBox.

    For me, VirtualBox Network Adapter 1 corresponds to le0, and 2 -> le1, and so on.

  • @GruensFroeschli:

    Just download the iso and load it as a cdrom in the virtualbox.
    Then install it normally as you would on real hardware.

    Does not work for me.  I get a working router, if you do not want the router to actually route anything.  Kinda makes the router broke, working but not.

    The router menu comes up, it assigns IP addresses, but it will not actually route any traffic to any NAT, Bridge, or Internal networks.  This How-To is wrong!  It does not work, at least on Ubuntu 9.04 with VBox 2.2.4

    Kevin Fries

  • Rebel Alliance Developer Netgate

    It most certainly does work for me, but may not work how you have it configured. VirtualBox is picky, and may not even work on two computers configured identically.

    I am running VirtualBox on Windows Vista on my Laptop and it works fine, I have not tried it on Ubuntu. It isn't very happy with my XP desktop, but I am not sure if it's XP, or if it's that it does not support VT and my laptop does.

    Also, this is not a "how-to", there is not current a how-to available. This thread was started by asking someone for a how-to, and we have replied just stating how things have worked for us.

    Always remember that just because something doesn't work for you, that does not mean it will not work for others.

  • Hi,

    I got it to work today on Ubuntu. see my experience report here:,17056.msg88585.html#msg88585


Log in to reply