Chrome Remote Desktop connection problem with Squid


  • Hi, all.
    I have problem with Chrome Remote Desktop connection.
    We have pfsense last release and updated squid, squidguard. Using LDAP authorisation and MITM. I have added my.local.ip/32 to ACLs>Unrestricted IPs and Authentication >Subnets That Don't Need Authentication.
    I have enabled ipv4+ipv6 in Listen IP Version
    I have added 74.125.247.128 to whitelist as regexp 74.125.247.128
    But when i try to connect to remote pc i have error with MITM enabled

    my.local.ip TCP_DENIED_ABORTED/200 0 CONNECT [2001:4860:4864:4:8000::]:3478 - HIER_NONE/- -
    my.local.ip TCP_DENIED_ABORTED/200 0 CONNECT 74.125.247.128:3478 - HIER_NONE/- -
    

    and with disabled MITM mode

    my.local.ip TCP_DENIED/403 3738 CONNECT 74.125.247.128:3478 - HIER_NONE/- text/html
    my.local.ip 192.168.207.140 TCP_DENIED/403 3787 CONNECT [2001:4860:4864:4:8000::]:3478 - HIER_NONE/- text/html
    

    i tried google this issue but no luck.
    Please give advice


  • Fresh news.
    When MITM enabled in Splice all mode - Chrome Remote Desktop is connecting.
    Even with removed ip 74.125.247.128 from ACL whitelist.
    Will try to compare config with this two modes and add this ip to exclusion list.