IPV6 No internet access - Mobile tethering / VM

  • Hi today i am having this issue and i have no idea what i have done to cause it.
    I tether my android samsung s8+ phone to my computer and use that connection for my virtual machine which has windows 7 installed. It has worked fine a long time. I even reinstalled my samsung android usb drivers on my PC. But whenever i go in my VM the connection always has that yellow question mark and "no internet access". in the screenshot i've attached when i click status on my network adapter connection, it says ipv6 no internet access. How do i fix this?
    I have tried these things but they have not helped:
    Reset Winsock And TCP/IP
    Release And Renew Your IP Configuration Settings
    Disable IP Helper Service
    Disable IPv6
    They however have not helped and i still can't get internet access in my VM. i have tried different VM's but they all have the same problem so it's obvious the issue is with the connection/network rather than the virtual machine which has not had its configurations changed ever. It has always been bridged adapter and worked fine. Also there is virtualbox hostonly network 1# and also a #2 enabled which i think has always been enabled as far as i know. I did recently install windows docker container but uninstalled that to make sure it wasn't causing any issue so i don't think that's it either. Also one thing to note is that in my original host O.S, the mobile data tether connection works fine, it's only when i use the vm that it gives me the no internet access error and doesn't work.
    Any help is appreciated, thanks.Screenshot_48.png Screenshot_46.png Screenshot_45.png