pfSense IPv6 RA RDNSS lifetime is too short (not compliant with RFC8106)


  • Is there a way to configure the lifetime for IPv6 RA RDNSS fields (type 25 and 31) in the pfSense IPv6 RA server? It appears that the default behaviour with pfSense is too short, and does not comply with RFC8106.

    pfSense only offers three configurable values in the "Router Advertisement" UI - the "Minimum RA interval" (default 5 seconds), "Maximum RA interval" (default 20 seconds), and "Router lifetime" (default 3 * maximum RA interval).

    Using these defaults, RA packets it sends have a router lifetime of 60 seconds as expected. However, the RDNSS fields have a lifetime of only 20 seconds! This causes them to occasionally expire if an RA packet is lost or if there is any jitter on the network.

    RFC6106 specified that the lifetime SHOULD be bounded as: MaxRtrAdvInterval <= Lifetime <= 2*MaxRtrAdvInterval

    RFC8106 superceded this specifically to address this problem, and specifies that the value of Lifetime SHOULD by default be at least:
    3 * MaxRtrAdvInterval

    The pfSense behaviour (as tested with 2.4.5-RELEASE-p1) barely meets the RFC6106 recommendation, and is way below what RFC8106 considers the minimum for reliable operation.

    Altering the MaxRtrAdvInterval in the pfSense UI doesn't help - pfSense appears to always set the lifetime of the RDNSS fields equal to MaxRtrAdvInterval.


  • I am seeing this as well.

    The radvd.conf is getting generated without AdvRDNSSLifetime defined, which from what I can find SHOULD default to 2*MaxRtrAdvInterval from what I am reading but it seems it is using just the MaxRtrAdvInterval.

    Adding AdvRDNSSLifetime {3*MaxRtrAdvInterval} to the config should fix it, and not require waiting for radvd to be fixed.

    Making this,

    	RDNSS 2001:470:****:1::3 2001:470:****:2::8 { };
    
    

    into this.

    	RDNSS 2001:470:****:1::3 2001:470:****:2::8 {
    	AdvRDNSSLifetime 3060 
    	};
    


  • Thanks for confirming, and opening the bug!


  • How can I make changes to the "radvd.conf" to work around this?

    I've tried editing the file, but it appears that every time the service is restarted via the pfSense GUI, the file is regenerated and my changes are lost.

    I've tried searching for a way to restart the service via the CLI but to no avail.


  • @csmith

    What happens if you make it read only, after you make the change?


  • @JKnott It still seems to be overwritten - I did a "chmod 444 /var/etc/radvd.conf", and the permissions seem to have stuck ("-r--r--r--"), but the contents of the file have reverted to the defaults after restarting the service.