ACME choosing wrong interface


  • Hello,

    I have a problem setting up the acme certificates when using openvpn.

    I have configured ACME to use the namecheap DNS, using their API and so forth, and whitelisting my public IP address in Namecheap web interface. Everything works fine and doing a "Issue/Renew" in the ACME Certificates page works properly and returns success.

    The problem arises when I also enable an openVPN connection, for some reason the ACME "Issue/Renew" keeps using that interface/IP address instead of the WAN address on the WAN interface. That doesn't work because that IP is not whitelisted on Namecheap server and may change without notice.

    Setting the default gateway in Advanced/Routing to the WAN gateway doesn't have any effect, neither simply removing the OpenVPN gateway from the list and just leaving the WAN gateway there. It seems that ACME picks the openVPN interface no matter what.

    I haven't tried creating a 3rd interface with openVPN, but I suspect it would pick that one, being the last one created.

    Any insight on how I can solve this?