Disable Cache Squid provoque WAN disconnection ?


  • Hi,

    I have tried to disable Cache in Squid Reverse Proxy. Do do that, I have following this recommendation on the following thread :

    https://forum.netgate.com/topic/45068/disable-cache-in-squid?_=1606726704558

    But when I use this settings (0 and null), my pfsense loose wan connection one time per day and I need to reboot after some hours..

    Each time, in the logs, I have those events :

    Nov 27 16:28:05 kernel e6000sw0port3: link state changed to UP
    Nov 27 16:28:05 check_reload_status Linkup starting e6000sw0port3
    Nov 27 16:28:03 check_reload_status Reloading filter
    Nov 27 16:28:03 php-fpm /rc.linkup: Hotplug event detected for WAN(wan) static IP ( )
    Nov 27 16:28:02 kernel e6000sw0port3: link state changed to DOWN
    Nov 27 16:28:02 check_reload_status Linkup starting e6000sw0port3
    Nov 27 16:27:36 check_reload_status Reloading filter
    Nov 27 16:27:35 php-fpm /rc.newwanip: rc.newwanip: on (IP address: ) (interface: WAN[wan]) (real interface: mvneta0.4090).
    Nov 27 16:27:35 php-fpm /rc.newwanip: rc.newwanip: Info: starting on mvneta0.4090.
    Nov 27 16:27:34 check_reload_status Reloading filter
    Nov 27 16:27:34 check_reload_status rc.newwanip starting mvneta0.4090
    Nov 27 16:27:34 php-fpm /rc.linkup: Hotplug event detected for WAN(wan) static IP ()
    Nov 27 16:27:33 kernel e6000sw0port3: link state changed to UP
    Nov 27 16:27:33 check_reload_status Linkup starting e6000sw0port3
    Nov 27 16:27:31 check_reload_status Reloading filter
    Nov 27 16:27:31 php-fpm /rc.linkup: Hotplug event detected for WAN(wan) static IP ()
    Nov 27 16:27:30 kernel e6000sw0port3: link state changed to DOWN
    Nov 27 16:27:30 check_reload_status Linkup starting e6000sw0port3

    At the beggining, I have thought that it's a coincidence because I don't understand why it's happening after changing this parameters...

    As I have no idea why it's happening and provoque this disconnection, I have reverted my change to the default 100 and UFS in cache settings. And no more disconnection...

    Do you have an idea ? Maybe it's a bug ?


  • @nanoupi42 said in Disable Cache Squid provoque WAN disconnection ?:

    Nov 27 16:28:02 kernel e6000sw0port3: link state changed to DOWN

    e6000sw0port3 is your WAN NIC ?
    If it wasn't you ripping out the cable, one or both sides, then I would check NIC's on both sides. Change also the cable.

    I'm not a Squid user, but I can't image why it would 'reset' the interface like that, in a 30 second time span.


  • Thans for your reply.
    Yes exactly, sorry I didn't precise that e6000sw0port3 is my WAN nic.

    We have changed the cables, and if I change my settiings to 0 and null, the problem occurs again.

    Really weird...


  • Hi,

    Just to update my thread, the issue occurs again this night...
    So you have right the issue is not related to Reverse Proxy...

    Exact the same thing in the log :

    Dec 3 01:44:55 php-fpm /rc.newwanip: rc.newwanip: on (IP address:) (interface: WAN[wan]) (real interface: mvneta0.4090).
    Dec 3 01:44:55 php-fpm /rc.newwanip: rc.newwanip: Info: starting on mvneta0.4090.
    Dec 3 01:44:54 check_reload_status Reloading filter
    Dec 3 01:44:54 check_reload_status rc.newwanip starting mvneta0.4090
    Dec 3 01:44:54 php-fpm /rc.linkup: Hotplug event detected for WAN(wan) static IP ()
    Dec 3 01:44:53 kernel e6000sw0port3: link state changed to UP
    Dec 3 01:44:53 check_reload_status Linkup starting e6000sw0port3
    Dec 3 01:44:51 check_reload_status Reloading filter
    Dec 3 01:44:51 php-fpm /rc.linkup: Hotplug event detected for WAN(wan) static IP ()
    Dec 3 01:44:50 kernel e6000sw0port3: link state changed to DOWN
    Dec 3 01:44:50 check_reload_status Linkup starting e6000sw0port3

    I really don't get it what is happen... I need to reboot the Pfsense to get my WAN interface up again...


  • These :

    @nanoupi42 said in Disable Cache Squid provoque WAN disconnection ?:

    Dec 3 01:44:50 kernel e6000sw0port3: link state changed to DOWN

    and

    Dec 3 01:44:53 kernel e6000sw0port3: link state changed to UP

    can be hardware events : the cable got disconnected for 3 seconds.
    As said before : bad connection ? The device upstream rebooted ?

    Or : dpinger detected to many ICMP losses, depending on the "Gateway Action"; it could 'kick' the interface.

    Or some pfSense package that goes haywire : de activate them all to be sure.

    edit :
    Their is a fourth possibility :

    @nanoupi42 said in Disable Cache Squid provoque WAN disconnection ?:

    (real interface: mvneta0.4090).

    Is this a VM ?
    if so, take the VM out of the equation.


  • Thanks for your reply, my gateway is setting like that :

    Capture d’écran 2020-12-03 à 08.57.49.png

    I have no monitoring on the gateway, but the Gateway Action is not tick.. Maybe I can enable that to see if it's a gateway action that disable the wan interface after losing some packets ?

    Also, we will change the ethernet cable this day to test...


  • @nanoupi42 said in Disable Cache Squid provoque WAN disconnection ?:

    Maybe I can enable that to see if it's a gateway action that disable the wan interface after losing some packets ?

    Just keep in mind : "No action" could mean that no scripts get executed (like DynDNS renew scripts) when a interface change happens.
    I'm not sure. It's worth to try - but follow closely what happens next.

    @nanoupi42 said in Disable Cache Squid provoque WAN disconnection ?:

    change the ethernet cable

    And this : use other NIC's.
    For example, change the WAN and LAN interface, as it is just a click click thing - and invert the LAN and WAN cable.
    If the problems moves to the LAN interface, you have your answer ^^


  • Hi,

    Just to update... We have changed our ethernet cable and I have tick the "disable Gateway action".

    We didn't have any issue since we did that :-)

    It will be interesting to confirm who is the culprit by uncheck the tick (disable gateway action), I will see if I do...

    Thanks !