Squid Proxy Server Service STOPS


  • Hello,

    We are using PfSense 2.4.5-RELEASE-p1 (amd64) with Squid 0.4.44_35 (3.5 Branch). The problem is that is Squid Services randomly stops time to time and service wont start again until I Clear Local Disk Cache.

    Error Log:

    Dec 3 08:58:04 nginx 2020/12/03 08:58:04 [error] 48250#100131: *1427190 "/usr/local/www/console/index.php" is not found (2: No such file or directory), client: 5.188.124.13, server: , request: "HEAD /console/ HTTP/1.1", host: "X.X.X.X"
    %(#000000)[Dec 3 09:31:47 kernel pid 94442 (squid), jid 0, uid 100: exited on signal 6
    Dec 3 09:31:51 kernel pid 14005 (squid), jid 0, uid 100: exited on signal 6
    Dec 3 09:32:45 kernel pid 16218 (squid), jid 0, uid 100: exited on signal 6
    Dec 3 09:33:45 kernel pid 42075 (squid), jid 0, uid 100: exited on signal 6]

    Any idea what's happening here why Squid keeps stopping?

    Thanks!


  • @briang70
    Yep, have same issue. I've solved this with disable MITM mode before, but today i tried clear cache and is helped.

    Dec 4 05:00:10 	kernel 		pid 85818 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:00:11 	kernel 		pid 86437 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:00:13 	kernel 		pid 96986 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:00:15 	kernel 		pid 654 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:00:16 	kernel 		pid 3896 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:00:18 	kernel 		pid 7281 (squid), jid 0, uid 100: exited on signal 6
    Dec 4 05:01:05 	Squid_Alarm 	81770 	Squid has exited. Reconfiguring filter.
    Dec 4 05:01:05 	Squid_Alarm 	82248 	Attempting restart...
    Dec 4 05:01:08 	Squid_Alarm 	90439 	Reconfiguring filter...
    Dec 4 05:01:08 	check_reload_status 		Reloading filter
    Dec 4 05:01:10 	php-fpm 	44241 	/rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
    Dec 4 05:01:10 	php-fpm 	44241 	/rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
    Dec 4 05:01:10 	php-fpm 	44241 	/rc.filter_configure_sync: [squid] Installed but not started. Not installing 'filter' rules. 
    

    in this thread we talking about it, and waiting for resolving
    https://forum.netgate.com/topic/153933/solved-squid-0-4-44_25-assertion-failed-http-cc-1533-comm-monitorsread-serverconnection-fd
    In PfSense redmine is created task https://redmine.pfsense.org/issues/10608
    Need to wait for new ported squid version for PfSense. In FreeBSD this issue already patched.