• Hey,

    So a few days ago I bought a wg x750e box. Came with mounting stuff and 2 CF disks, 1x 512 disk which had the WG OS on, I could access the web interface etc. and 1x 4GB disk with apparently pfSense on.

    I followed many tutorials on how to install pfSense, and here is how I failed that. So the tutorial says to flash FreeDOS on to the 512MB disk with Win32DiskImager, so, I do. I use a null modem cable connected to the console port and a serial to USB adapter in my PC using Putty (on COM5) as the terminal. So I turn it on and on the screen is pfSense B8 and it gets stuck on Booting OS... Putty is just generating this line of weird characters (pictured).

    53a6733e-4b2e-4d9d-978b-44b36b90e76f-image.png

    It does the same for when I flash pfSense on to the 4GB one, but it says Memory Test Passed and nothing else. It's reallya nnoying and can't seem to understand it. Oh also, it just beeps once as well and that's it.

    Another thing - when I press the Delete key, it beeps and adds another one of those weird line thingys. Help would be much appreciated.

    Jaxx.

  • Netgate Administrator

    The BIOS output will be at 9600bps by default.

    There is no current pfSense image that will run on that box though, they are 32bit only. What image are you trying to use?

    Have a look here:
    https://web.archive.org/web/20171205175929/https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#X-Core-e

    If the LCD shows 'pfSense B8' the BIOS is already on the most recent version so you should only need the correct putty settings to access it. It might be at 115200bps since it's already been flashed.
    If the settings are default it should also boot most CF cards without needing to change anything

    Steve


  • @stephenw10 Hi Steve,

    I just followed the tutorials. I went to download on the pfSense website, selected ADM64, Serial and the mirror and flashed it.

  • Netgate Administrator

    Ok, the serial memstick is for installing onto something else, like a harddrive. But the current pfSense image, 2.4.5p1, is 64bit only. It won't boot on that box.

    The last version that was build as 32bit was 2.3.5 and if you wanted to run from the CF card directly you would need the Nano image. You can probably find that somewhere but you really shouldn't be running that any longer as it's old and unsupported. It has known issues.

    Steve


  • This post is deleted!

  • @stephenw10 Ok so I downloaded the "pfSense-CE-2.3.5-RELEASE-2g-amd64-nanobsd.img.gz" version and extracted it and flashed it etc. It did load on Putty - however it just came up with this (attached) - what do I do from here?!

    2c3fd8d6-f769-417f-8c37-572e7d61225b-image.png


  • @musicjaxx You cannot use a 64bit version on this box!

    32bit only!

    amd64 versions will not work.


  • @chpalmer Oh I only just noticed that, dang.

    Thank you, I'll try from "pfSense-CE-2.3.5-RELEASE-2g-i386-nanobsd.img.gz".


  • Ok, I'm back and it started to boot - but decided to throw some errors at me.

    bb1854ca-c35c-4b8e-9ca4-1d500285cc6a-image.png

  • Netgate Administrator

    That looks like a bad CF card.

    Or it could be you need to force PIO mode since it's trying to run UDMA and I believe the CF slot is missing the pins for that.
    https://docs.netgate.com/pfsense/en/latest/troubleshooting/boot-issues.html?highlight=pio#pfsense-2-2-and-later

    Or maybe disable that in the BIOS since I don't recall ever having to set that....

    Steve


  • @stephenw10 I tried to put a bios on it, but the 1st CF card is 512 MB but apparently it has to be a certain size lower or something

  • Netgate Administrator

    @musicjaxx said in Watchguard x750e - Help!!:

    pfSense B8

    If the screen shows that when you first turn it on that means it already has the most recent BIOS on it. You do not need to flash it again.
    That also means you should be able to access the BIOS via the serial console, press TAB, and make changes there.
    And it is trying to boot that 4GB card which it otherwise would not at all.

    Steve


  • @stephenw10 Thank you, I will give it a try later on tonight.

    Last time I tried pressing Tab or Del, it made like some sort of dull very short beep, where as the normal beep is longer and more clear to hear if that makes sense.


  • @stephenw10 Hello again,

    Tried pressing tab, kept making a dull beep sound and didn't boot into the BIOS.

  • Netgate Administrator

    If it has the current BIOS you should see the POST screen at 115200bps that looks something like:

       Phoenix - AwardBIOS v6.00PG, An Energy Star Ally
       Copyright (C) 1984-2003, Phoenix Technologies, LTD
    
    (E17HDD) MOD V0.81 console on com1 115200. Stephenw10 12/4/2014
    
    Main Processor : Genuine Intel(R) processor 1.30GHz(100x13.0)
    Memory Testing :  523264K OK +  1M shared memory
    
    IDE Channel 0 Master : CHN-25PATA01M 20140121
    IDE Channel 0 Slave  : None 
    
    
    
    
    
    
    
    
    
    
    
    
    Press DEL to enter SETUPKA    
    

    Then you hit TAB to access the setup. Where there are oprions to disable UDMA mode for the attached drives in Integrated Peripherals > OnChip IDE Device like:

    +=====================================================+========================+
    |    IDE HDD Block Mode        [Enabled]              |        Item Help       |
    |    IDE DMA transfer access   [Enabled]              |------------------------|
    |    On-Chip Primary   PCI IDE [Enabled]              | Menu Level   **        |
    |    IDE Primary Master PIO    [Auto]                 |                        |
    |    IDE Primary Slave  PIO    [Auto]                 |                        |
    |    IDE Primary Master UDMA   [Auto]                 |                        |
    |    IDE Primary Slave  UDMA   [Auto]                 |                        |
    |                                                     |                        |
    |    *** On-Chip Serial ATA Setting ***               |                        |
    |    On-Chip Serial ATA        [Disabled]             |                        |
    |  x PATA IDE Mode              Secondary             |                        |
    |    SATA Port                  P0,P2 is Primary      |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    +=====================================================+========================+
    

    One thing to note is that the BIOS console access requires a cable wired for hardware flow control. A 3 wire cable will work in pfSense but not to access the BIOS or with FreeDOS.

    Steve


  • @stephenw10 I can't see this when I connect to it. I'm just going to buy a standard mini pc thing and boot from USB as it's much easier and works haha. Thank you for the advice though.

  • Netgate Administrator

    That's a better idea since even if you did get this to boot it would be 3 years out of date! 😉