Pfsense wechselt DSL Anschlüsse


  • Hallo zusammen,

    ich habe ein Problem mit der PFsense (logisch) :)

    Pfsense Version 2.4.5+Patch

    und zwar ich habe 2x DSL mit 2 Draytec Modems(per Brigde eingestellt) , die Pfsense wählt sich Per PPPOE ein (bei beiden).. soweit so gut.
    Eine DSL ist eine 6Mbit (WAN) und der zweite hat 3,5mbit WAN2.. der 6Mbit ist mein haupt Anschluss..aber egal das ist nicht das Problem.
    Beim Einrichten funktioniert alles noch.. Auf jeden fall Vertauscht die PfSense einfach die DSL anschlüsse,dh. mein Hauptanschluss ist dann der 3,5Mbit ..und ich bekomme das nur durch mehrfachen neustarts der Pfsense oder der Modems in den Griff und das nervt einfach :)))) (klappen tut es auch wenn ich kurz die beiden Lan Kabel von den Modem abziehe)

    Aufgefallen ist es mir durch den Jdownloader und das kein Telefon mehr geht (Fritzbox)
    Ohne das jemand dabei war weder mit Kabel tauschen noch sonst einer sache. Die Pfsense habe ich schon X mal neu aufgesetzt bzw versucht umzukonfigurieren (Modems auf andere Lan Ports)

    das ich langsam keine Lust mehr habe auf das ding :( könntet ihr mir bitte Tips geben oder wie kann ich weiter verfahren????
    Welche Screenshots braucht ihr noch?

    achja die PFsense nutze ich ohne load balancing oder Fail-Over
    ganz normal jedes Netz einen DSL Anschluss..

    Mfg Thomas

    						Pfsense 	(Netzaufbau)	
    					
    			             mit	4 Netzwerk Karten			
                     2 Draytec Modems               2xWan				
    						1xLan                     ----> Switch 
    						1xLan VLAN	      ----> Switch
    

    Pfsense 1.PNG DSL Download.PNG


  • @bonedaddy
    wir haben hier das selbe Setup (allerdings ohne ipv6), läuft ohne Probleme.

    Die Modems hängen an zwei Ethernet Ports?
    System / Routing / Gateway Groups ist leer?
    Du bekommst zwei unterschiedliche Gateways je WAN Anschluss?
    Wie ist die Uptime der Anschlüsse?
    Welcher Gateway ist unter System / Routing / Gateways markiert (Weltkugel)?


  • @slu
    Hi, ja die Modems hängen an 2 Ethernet Ports.
    als Standart dient mein DSL Anschluss WAN_PPPOE, wenn ich bei Standartgateway kein
    bzw Automatisch kann ich pfblockerng nicht aktualisieren.

    über die Uptime der Anschlüsse kann ich nix genaues sagen durch mein ständiges Probieren und
    neu starten weiß ich es nicht..

    Gateway2.PNG Gateway.PNG
    IP_Adressen.PNG

    ja und das Gateway scheint bei beiden gleich zusein?!?!
    das wird mir aber doch von der Telekom zugeteiltsoweit ich weiß...

    WAN1.PNG
    WAN2.PNG

  • LAYER 8 Rebel Alliance

    Hast du mal bei beiden Gateways eine externe und unterschiedliche Monitor IP gesetzt?
    Also z.B. WAN 8.8.8.8 und WAN2 8.8.4.4
    Normal hätte ich ja gesagt die selbe Gateway IP geht auf keinen Fall, in der Doku steht allerdings folgendes:

    Due to the way pf handles multi-WAN connections, traffic can only be directed using the gateway IP address of a circuit, which is fine for most scenarios. If the firewall has multiple connections on the same ISP using the same subnet and gateway IP address, as is common when using multiple cable modems, an intermediate NAT device must be used on all but one of them so that the firewall sees each WAN gateway as a unique IP address.

    When using the NAT device, it can be configured to forward all traffic back to the firewall which can help with using that WAN for other services. However, some protocols, such as VoIP, will have problem if they use a WAN with NAT in such a configuration.

    If at all possible, contact the ISP and have them configure the WAN circuits such that they are in different subnets with different gateways.

    One exception to this is a PPP type WAN such as PPPoE. PPP type WANs are capable of having the same gateway on multiple interfaces, but each gateway entry must be configured to use a different monitor IP address.

    -Rico


  • @rico
    danke für den Hinweis, wieder was gelernt!


  • @rico
    Ich hatte die Überwachung der Gateway ausgestellt.
    habe deinen Tip umgesetzt und verschiedene Monitor IP`s eingestellt..
    mal schauen.
    ich würde übernacht das ganze mal testen.
    sonst müsste ich halt die Draytec die PPPOE Einwahl erledigen lassen ..
    Mfg


  • @bonedaddy said in Pfsense wechselt DSL Anschlüsse:

    sonst müsste ich halt die Draytec die PPPOE Einwahl erledigen lassen ..

    Geb nicht so schnell auf, es gibt irgend einen Grund für dieses Problem ;)


  • @slu
    du weißt nicht wie lang ich schon daran herumspiele :)))))

  • LAYER 8 Rebel Alliance

    Im worst case machst du auf einem der beiden WANs NAT.
    Aber lt. Doku sollte es ja eigentlich gehen.

    -Rico

  • LAYER 8 Moderator

    @rico said in Pfsense wechselt DSL Anschlüsse:

    Im worst case machst du auf einem der beiden WANs NAT.
    Aber lt. Doku sollte es ja eigentlich gehen.

    -Rico

    Jup was Rico sagt. Bin gespannt ob es läuft aber als ichs gelesen habe, wollte ich gleich schon "gleiches Gateway" sagen ;) Typisch für 2x gleicher Anbieter. Normalerweise löst mans wirklich wie in der Doku mit eigenen GWs also Router mit exp host vorne dran. Dass es bei PPPoE auch so geht - bin gespannt. Auf jeden Fall nicht das Monitoring abschalten und eigene MonIP pro GW setzen. Ggf eines per 8.8.8.8 und eines per 9.9.9.9 damit komplett andere Netze.


  • Hallo zusammen, und Frohes neues euch allen :))


  • so nun zu der Pfsense, ich glaube ich kann das Problem reproduzieren.
    Heut morgen hatte ich mein Haupt DSL neugestartet weil das Radio abgehakt klang ..
    nun hat das Modem konnte keine verbindung nach dem Neustart herstellen. Auch nach längerrem warten und 3 Neustarts nix zuwollen.
    bei dem letzten reboot bin ich zur Pfsense Oberfäche gewechselt und habe gesehen das PFsense meinen WAN2 einfach als WAN eingesetzt hat., nachdem mein Hauptmoden fertig war wurde es fleißig als WAN2 eingesetzt.. Toll, ich bin mir zwar ziemlich sicher das ich das nicht eingestellt habe.. nun ja habt ihr ne idee wo ich schauen kann?.. Bei den Gateways habe ich nix konfiguriert..

    Twi_Ipv6_Gateway.PNG Twi_Gateway.PNG Ellis_ipv6_Gateway.PNG Ellis_Gateway.PNG


  • @bonedaddy
    Ich kann dir nicht sagen ob es die Lösung ist, aber konfiguriere vielleicht doch mal eine Gateway Gruppe.
    FallBackVDSL
    Tier 1 VDSL1
    Tier 2 VDSL2

    Das ganze (FallBackVDSL) setzt Du dann in System / Routing / Gateways als Default gateway IPv4 ein.


  • @slu
    Nabend,
    ich bin für jede Idee offen, da ich ja selber keine Lösung habe 😉
    ich werde es gleich mal ausprobieren..
    danke

  • LAYER 8 Moderator

    Ohne Überwachungsaktion wird ein Gateway auch nicht rausgenommen oder abgeschaltet. Dann kann im Normalfall die GW Gruppe nicht wirklich greifen. Wo sind die GWs denn überhaupt eingestellt und verbaut? Wie sehen die NAT Regeln und Firewall Rules aus? Werden die Anschlüsse jetzt immer noch "vertauscht" (was technisch eig. gar nicht geht)? Etc etc.