• I have some problem with devices hooked to my LAN and their support suggested that I should reset my network router's cached addresses (which is pfSense).
    How do I reset pfSense's cached addresses?


  • @zkab
    What do they mean with cached addresses? MAC adresses like ARP Table or DNS Entries or DHCP Entries? Reboot pfsense does not solve the problem?

    ARP Table entries normally expire over time (even in your switch). DNS Entries may gone when you restart the DNS Resolver if they are not defined. If he depend on your DHCP Server then restart DHCP Server.

  • LAYER 8 Global Moderator

    A statement of cached addresses would have me thinking dns.. Simple restart of unbound would flush its cache. Clients local cache can be flushed, if windows with ipconfig /flushdns

    What exactly is the problem your having?

    But as already mentioned arp, are temp - pfsense default to a 20 minute lifetime for arp entries. But they can be flushed as well, either all of them or specific ones.. To remove specific just call up the arp table in diag menu, and you can delete specific entries with the trashcan icon


  • @bon-go said in Cached addresses:

    @zkab
    What do they mean with cached addresses? MAC adresses like ARP Table or DNS Entries or DHCP Entries? Reboot pfsense does not solve the problem?

    I will ask their support what they mean ...
    Reboot didn't solve the problem.

    @johnpoz said in Cached addresses:

    What exactly is the problem your having?

    This is my problem ...
    ----------------------
    
    My LAN is both wired & WiFi.
    The range of local IP addresses are 192.168.1.1-192.168.1.255
    All cables are Cat. 6
    
    Internet connection goes into a computer that runs only PfSense 2.4.5-RELEASE-p1 (amd64) that is my router & firewall.
    From PfSense goes the traffic into a Netgear switch where all my equipments are hooked.
    The WiFi is using Unifi Cloud Key & Unifi Access Points (PoE) connected to the switch.
    
    I don't think the problem lies in my network environment but rather in the BluOS Controller app ... I have tested it with Google Pixel 4XL (Android 11) and Samsung Galaxy S8 (Android 9) with the same result ... I will explain why I think so.
    
    My players are M12 & PULSE FLEX 2I both wired to my network switch.
    I have given them fixed IP addresses.
    When I give one of the fixed IP:s in my mobile Chrome browser it shows me correctly the Control Panel for that player and when I click at 'Show Your Other Players' it shows me correctly the Control Panel for the other player.
    I can also ping the players.
    Spotify finds both players without any problem.
    So it seems that all software except BluOS Controller app are working OK in my LAN.
    
    This is what Bluesound Support Crew answered ...
    ------------------------------------------------
    
    The issue you are seeing is not firmware related, as I and my colleagues have been able to access the players via our android without any issues.
    Additionally, there have been no updates made to the Android app since late November. 
    Though I do have to say given the information you have provided it is curious that your phones cannot see the players in-app but still access them via IP. 
    
    I believe this may have to do with the network device table of your router. Please follow the steps below:
    
        Please power down your players and any other network-attached devices. (Laptops, tablets, and smartphones
        you can simply put in Airplane Mode).
        Unplug your router for 30 seconds then plug it back in
        Wait 5 minutes
        Start powering up all your Players and network devices.
        Reconnect your tablets and laptops
        Relaunch the app
    
    
    This will reset your network router's cached addresses.
    
  • LAYER 8 Global Moderator

    This has zero to do with pfsense - and has to do with your wireless to wired network. Your prob blocking multicast..

    You should look for help on the unifi forums..

    Your phone (on wifi) can not discover something. That is the problem right? Then it prob has something to do with these 2 settings.

    multicast.png

    Or just an issue with what firmware your running? What firmware are you running on the AP? What controller software? Are you doing any sort of captive portal, etc...

    Again - pfsense has ZERO to do with devices talking to each other on the same network, and have zero to do with any sort of broadcast or multicast traffic between devices on the same L2 network be that wired or wireless.

    That response from them is saying they don't have a clue! Routers would have NOTHING cached that would have anything to do with this.. You could turn off your router (pfsense) its not involved in anything going on here.

  • Netgate Administrator

    @zkab said in Cached addresses:

    network device table

    ๐Ÿ™„

    Yeah, what @johnpoz said. ^


  • @johnpoz said in Cached addresses:

    That response from them is saying they don't have a clue!

    I agree with you 100% ...

    I am not an expert but it seems that blocking multicast could be the reason.
    In Unifi I have both 'Block LAN to WAN Multicast and Broadcast Data' & 'Enable multicast enhancement (IGMPv3)' unchecked ... those in your screenshot ... should they both be unchecked?
    But I guess that 'Auto-Optimize Network' should be off and my problem will be solved ...
    unifi-2.png

  • Netgate Administrator

    Yes, you need wireless to wired broadcast or the app won't be able to 'discover' the players.

    Of course the app developers could have just given you an option to enter the player IP since it's static but like many they probably consider that far outside the comprehension of their average user. Or they don't understand it themselves. ๐Ÿ™„ /endrant!

    Steve

  • LAYER 8 Global Moderator

    @stephenw10 said in Cached addresses:

    Of course the app developers could have just given you an option to enter the player IP

    A 1000's times this!! Why these makers limit their products is beyond me.. Sure let it discover sure - but for anyone else that might be a bit more advanced network.. More and more people are segmenting their network.

    A simple way for IP or even just fqdn of the device, and listing what ports are required would be so freaking simple.. And remove all of these issues with discovery..


  • I agree with you.
    Many thanks for taking your time and helping me in a very professional way!!!