• I am trying to get QinQ working with a simple ping. I have setup packet capture for debugging and see can see the traffic coming in and an ARP response, but TNSR is not responding to the ping. Am I missing something?

    Packet capture:

    packet.PNG

    Config:

    <dataplane-config xmlns="urn:netgate:xml:yang:netgate-dataplane">
       <dpdk>
          <dev>
             <id>0000:0b:00.0</id>
             <name>PORT1</name>
          </dev>
          <dev>
             <id>0000:0b:00.1</id>
             <name>PORT2</name>
          </dev>
          <dev>
             <id>0000:0b:00.2</id>
             <name>PORT3</name>
          </dev>
          <dev>
             <id>0000:0b:00.3</id>
             <name>PORT4</name>
          </dev>
          <uio-driver>igb_uio</uio-driver>
       </dpdk>
       <statseg>
          <heap-size>96M</heap-size>
          <per-node-counters>
             <enabled>false</enabled>
          </per-node-counters>
       </statseg>
    </dataplane-config>
    <interfaces-config xmlns="urn:netgate:xml:yang:netgate-interface">
       <interface>
          <name>PORT4</name>
          <enabled>true</enabled>
       </interface>
       <interface>
          <name>PORT4.40012</name>
          <enabled>true</enabled>
          <ipv4>
             <address>
                <ip>10.2.0.1/24</ip>
             </address>
          </ipv4>
          <bridge>
             <bdi>10</bdi>
             <shg>0</shg>
          </bridge>
       </interface>
       <interface>
          <name>local0</name>
       </interface>
       <interface>
          <name>loop1</name>
          <enabled>true</enabled>
          <ipv4/>
          <bridge>
             <bdi>10</bdi>
             <bvi>true</bvi>
             <shg>0</shg>
          </bridge>
       </interface>
       <interface>
          <name>tap30</name>
          <enabled>true</enabled>
       </interface>
       <bridge-table>
          <bridge-entry>
             <bdi>10</bdi>
             <flood>true</flood>
             <uu-flood>true</uu-flood>
             <forward>true</forward>
             <learn>true</learn>
          </bridge-entry>
       </bridge-table>
       <loopback-table>
          <loopback>
             <name>bridgeloop</name>
             <instance>1</instance>
          </loopback>
       </loopback-table>
       <subinterfaces>
          <subif-entry>
             <if-name>PORT4</if-name>
             <subid>40012</subid>
             <vlan>
                <dot1ad>true</dot1ad>
                <outer-vlan-id>4001</outer-vlan-id>
                <inner-vlan-id>2</inner-vlan-id>
             </vlan>
          </subif-entry>
       </subinterfaces>
       <tap-table>
          <tap>
             <host-name>capture</host-name>
             <host-namespace>dataplane</host-namespace>
             <instance>30</instance>
          </tap>
       </tap-table>
    </interfaces-config>
    <kea-config xmlns="urn:netgate:xml:yang:netgate-kea">
       <keactrl>
          <dhcp4>
             <enable>true</enable>
          </dhcp4>
       </keactrl>
       <dhcp4-server>
          <Dhcp4>
             <option-data>
                <name>domain-name</name>
                <data><![CDATA[]]></data>
             </option-data>
             <description><![CDATA[]></description>
             <lease-database>
                <type>memfile</type>
                <persist>true</persist>
                <lfc-interval>0</lfc-interval>
             </lease-database>
             <interfaces-config>
                <interfaces>
                   <interface>local0</interface>
                </interfaces>
                <interfaces>
                   <interface>loop1</interface>
                </interfaces>
                <dhcp-socket-type>raw</dhcp-socket-type>
             </interfaces-config>
             <subnet4>
                <subnet>10.2.0.0/24</subnet>
                <interface>loop1</interface>
                <option-data>
                   <name>domain-name-servers</name>
                   <data><![CDATA[8.8.8.8, 8.8.4.4]]></data>
                </option-data>
                <option-data>
                   <name>routers</name>
                   <data><![CDATA[10.2.0.1]]></data>
                </option-data>
                <pools>
                   <pool>10.2.0.128-10.2.0.191</pool>
                </pools>
             </subnet4>
          </Dhcp4>
       </dhcp4-server>
    </kea-config>
    <nat-config xmlns="urn:netgate:xml:yang:netgate-nat">
       <ipfix>
          <logging>
             <domain>1</domain>
             <src-port>4739</src-port>
          </logging>
       </ipfix>
       <nat64>
          <ngmap:map xmlns:ngmap="urn:netgate:xml:yang:netgate-map">
             <ngmap:parameters>
                <ngmap:security-check>
                   <ngmap:enable>true</ngmap:enable>
                </ngmap:security-check>
             </ngmap:parameters>
          </ngmap:map>
       </nat64>
    </nat-config>
    <route-config xmlns="urn:netgate:xml:yang:netgate-route">
       <dynamic>
          <ngbgp:bgp xmlns:ngbgp="urn:netgate:xml:yang:netgate-bgp">
             <ngbgp:global-options>
                <ngbgp:enable>false</ngbgp:enable>
             </ngbgp:global-options>
          </ngbgp:bgp>
          <ngfrr:manager xmlns:ngfrr="urn:netgate:xml:yang:netgate-frr">
             <ngfrr:global-options>
                <ngfrr:ptm>false</ngfrr:ptm>
             </ngfrr:global-options>
          </ngfrr:manager>
          <ngospf:ospf xmlns:ngospf="urn:netgate:xml:yang:netgate-ospf">
             <ngospf:global-options>
                <ngospf:enable>false</ngospf:enable>
             </ngospf:global-options>
          </ngospf:ospf>
          <ngospf6:ospf6 xmlns:ngospf6="urn:netgate:xml:yang:netgate-ospf6">
             <ngospf6:global-options>
                <ngospf6:enable>false</ngospf6:enable>
             </ngospf6:global-options>
          </ngospf6:ospf6>
          <ngrip:rip xmlns:ngrip="urn:netgate:xml:yang:netgate-rip">
             <ngrip:global-options>
                <ngrip:enable>false</ngrip:enable>
             </ngrip:global-options>
          </ngrip:rip>
       </dynamic>
    </route-config>
    <snmp-config xmlns="https://netgate.com/ns/netgate-snmp">
       <snmp-enable>false</snmp-enable>
    </snmp-config>
    <span-config xmlns="urn:netgate:xml:yang:netgate-span">
       <span-table>
          <source>
             <if-name-src>PORT4</if-name-src>
             <destination-table>
                <destination>
                   <if-name-dst>tap30</if-name-dst>
                   <layer>hw</layer>
                   <state>both</state>
                </destination>
             </destination-table>
          </source>
       </span-table>
    </span-config>
    <unbound-config xmlns="urn:netgate:xml:yang:netgate-unbound">
       <server>
          <do-ip4>true</do-ip4>
    
  • LAYER 8 Netgate

    @dbeyzade I assume you're capturing in the host shell on the capture interface presented there.

    Your screenshot does not show any ping attempts.

    Is it possible to capture your entire test and post the pcap file instead of a screen shot?

    The same on the connected switch port would be nice as well.

    Thank you.