Squid not on 2 interfaces?

  • In squid one can assign several interfaces for it to listen on. When I choose a socond one (OPT1) and saved I noticed nothing special, service still running according to services page etc. But now when I looked at the lighsquid page it's clear that logging stopped when I did that config change.


  • I have squid enabled in two interfaces and working good. what is your squid version?

  • Forgot that info.. it's 2.6.21_10

  • Well well well…. I now tried to upgrade to latest and this yielded me a dead lightsquid instead... get a 404 on that page.


  • Ok, problem still there after reboot and I'm getting pissed.
    Why did the squid upgrade kill lightsquid?

    –- time elapses....

    I reinstalled GUI components for lightsquid and that did the trick, at least logs from oct 23 shows up after full refresh of db.
    If logging on second interface actually work I cannot say now, I'll return if it doesn't.

    So, obviously using 2 interfaces doesn't work in previous versions of squid then.

  • Just reinstall lightsquid. It worked for me.

Log in to reply